Endpoint Protection for Macintosh client requests authentication credentials for anonymous LiveUpdate proxy

book

Article ID: 163938

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

Symantec Endpoint Protection (SEP) for Mac runs LiveUpdate and prompts for Network Proxy Authentication credentials even though the configured proxy is anonymous.

When LiveUpdate is launched, a dialog box appears requesting user name and password for Network Proxy Authentication.

Cause

The Mac LiveUpdate Cross-Platform engine (LUX) is not correctly interpreting system proxy settings.

 

Environment

  • SEP for Mac version 14 or later (managed or unmanaged client)
  • Mac OS X 10.9 and later
  • Mac system is configured to use an anonymous proxy for http connections

Resolution

This problem is fixed in Symantec Endpoint Protection 14 RU1.

Please note, even in SEP 14 RU1 you may receive a prompt for proxy credentials if the proxy address/port or LiveUpdate server cannot be reached, or if the proxy is of an unsupported type. SEP Mac LiveUpdate supports only HTTP(S) proxies; FTP/SOCKS proxies are unsupported. Proxy automatic configuration (via PAC file, etc) is supported (there was an Apple bug in macOS 10.13 and 10.13.1 that intefered with LiveUpdate and proxy auto-config, but this was addressed by Apple in macOS 10.13.2).

For information on how to obtain the latest build of Symantec Endpoint Protection, read ‘Download the latest version of Symantec Endpoint Protection’
http://www.symantec.com/docs/TECH103088