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PMImport Fails after Patch Management solution repair: Invalid object Inv_Software_Update in log files

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Article ID: 155380

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Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

Repaired Patch Management Solution 7.x per HOWTO47868 and found the PMImport failed with numerous error entries in the SMP Log Viewer; one for each bulletin being imported.

Also found the same error was thrown when opening the Console > Actions > Software > Patch Remediation Center; highlight Software Bulletin > Right-click > Download/Recreate Packages.

An unexpected exception  occured  (GUID: 74b5cf1e-d756-4ea1-8efd-83eaf5af9176) DataClassTable: Inv_Software_Update, Eception: System.Data.SqlClient.SqlException: Invalid object name 'Inv_Software_Update'

Environment

Patch Management 7.5.x

 

Cause

The repair was unable to successfully restore associations from the Inv_Software_Update table to the DataClass resources.

 

Resolution

Worked through the following remedial steps:

  1. RDP to a working SMP with the same ITMS Version
  2. Opened the Console > Settings > All Settings > Notification Server > Resource and Data Class Settings > Data Classes > Software Management > Patch Management > Global 
  3. Highlighted the Software Update DataClass, right-click > Export; saved file
  4. Imported the saved Software Update DataClass to non-working SMP Console > Settings > All Settings > Notification Server > Resource and Data Class Settings > Data Classes > Software Management > Patch Management > Global 
  5. Worked through the repair process outlined on HOWTO47868
  6. Confirmed restored resource associations; PMImport completed download process and Software Updates able to download in the PRC