Patch Management Licensing and Client Inventories fail to return to the Notification Server.

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Article ID: 155096

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Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

Licensing fails to portray the proper count of clients.

Reporting does not display the proper count of clients.

Microsoft Vulnerability Analysis Policy is targeting the proper client count for the filter: 'Computers with Software Update Plug-in Installed'

 

Cause

All required packages are not included in the Software Update Plug-in Package.

Clients fail to obtain all needed packages, they report as having the Plug-in, but they do not have the ability to return Patch Inventories and request a license.

Resolution

Please review the following:

  1. Run the following SQL Script to view the License In Use table and ensure the client is pulling a valid license:
    • DECLARE @Product AS NVARCHAR (200)
      --Enter the guid of the solution or its name.  
      --If it is only part of the guid or name make sure to use % symbals as needed. 
      SET @Product = '%Patch%'

      SELECT vp.Name, vc.Name, vc.Domain, liu.* 
      FROM LicenseInUse liu
      JOIN vProduct vp ON vp.Guid = liu.LicensingPolicyGuid
      JOIN vComputer vc ON vc.Guid = liu.ResourceGuid
      WHERE vp.Name LIKE @Product OR vp.Guid LIKE @Product
      ORDER BY vp.Name, vc.Name
       
  2. Check to ensure the Microsoft Vendor Policy / Resources are in order
  3. Check client to ensure it has packages
    • Software Update Plug-in
    • Windows System Assessment Scan 
    • Patch Install Tools
  4. Check the Package Server GUI to ensure the packages are received
    • Note: Patch Windows System Assessment Scan = name of package
    • Check the GUI and run Update Package / Refresh Package / Resend Package info
      • All buttons on the Package Server tab to refresh
    • Check the Logs to see if there are any problems
       
  5. Check the settings on the Console
    • Ensure the Sites are targeted properly within the subnet
    • Ensure the package servers have the Task Server Services installed
    • Ensure the package servers in each subnet / site have at least 1 Unconstrained Package Server to pull packages from the NS (Constrained = only pulls packages from other Package Servers in the subnet / site).
    • Look here for pre 7.1 SP1 environments to resync
    • 7.1 SP1 Environments:
      • From the Package Server
        • Stop the agent service
        • Delete all snapshot.xml files from all subfolders under “.\Program Files\Altiris\Altiris Agent\Package Delivery\” (this is not the same as deleting them on the NS, which is what I oppose doing.
        • Delete all folders and contents under “.\Program Files\Altiris\Altiris Agent\Package Server Agent\PackageStatus\”
        • Start the agent service
            Advisory: Some NS Core engineers still use the KM in SP1 without problems, but one Backline Engineer has advised against it.
    • Ensure the Vendor Policy > Policy and Package Settings are in order
  6. The Client should have the Package at this point –
  7. Review the following for troubleshooting failed PMImport:

 Informational: See How does managed client consume a Patch Management Solution license for 7.1 SP2+, 7.5, 7.6 and 8.0? for more details regarding how a Patch Management License is consumed and how to free up the license in use.

 

Applies To

 

Patch Management 7.1 SP1, SP2, MP1.x and 7.5