Updating downloads in an internal LiveUpdate Administrator 2.x Server using the downloads from an external LiveUpdate Server
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Updating downloads in an internal LiveUpdate Administrator 2.x Server using the downloads from an external LiveUpdate Server

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Article ID: 151656

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Updated On:

Products

Mail Security for Microsoft Exchange Endpoint Protection

Issue/Introduction

To update clients in a High Security Network that does not have internet access or access to the rest of the network, you have installed a LiveUpdate Administrator 2.x server.  You wish to manually update this internal LUA 2.x server from another LUA 2.x server in a DMZ ("external server") using a CDROM, USB drive, flash drive or similar media.


 

Cause

LiveUpdate Administrator 2.x requires access to LiveUpdate source servers on the Internet in order to function as designed.  It is possible to use LUA 2.x on an isolated network, but it will require manually copying update files from another LUA 2.x. 

Resolution

Configuring the downloads and the distribution on the external server (DMZ server with Internet access).

Configuring Downloads

  1. Access the LUA 2.x server's GUI. Double-click on the LiveUpdate Administrator Icon on the desktop or use your Internet Browser to connect to the web interface. The default login location if accessing from a remote computer is http://<IP_of_LUA_2.x_server>:7070/lua/logon.do  
  2. Log into the LUA 2.x server using your user name and password
    NOTE: to add or change download options, you must be logged into the LUA 2.x server as an administrator
  3. Click on the Configure tab
  4. Update your Symantec Product Catalog (SPC) by clicking on "Update Symantec Product Catalog". Once this is complete, move to step 5
  5. To add a new product, click "Add New Products"
  6. Select the products you would like to update.
    1. Click on the "Product Line" you would like to add to LUA 2.x
    2. Under "All Products", choose the versions you would like to update
    3. Once you have finished with selecting the Products for the Product Line selected in step a., click OK
    4. If you would like to add more products, start with Step 5



Source Servers

Source servers are the locations from which LUA 2.x downloads its content. When you install the LiveUpdate Administrator, the Symantec LiveUpdate server at http://liveupdate.symantecliveupdate.com is added by default. LiveUpdate Administrator 2.x will download updates from the server with the highest priority if updates with the same timestamp are available on all source servers. The failover server list displays similar information for the failover servers associated with the source server. The list of failover servers is in the order that a connection will be attempted in cases where you cannot connect with the source server. You can change the order of the failover servers by clicking Edit , and then selecting the failover server to move up or down in the list.

Then you need to configure also a distribution on that server.

Configuring Distribution Centers

Before creating Distribution Centers (DCs), we need to create a user account that will only have permission to the folder to which the content will be downloaded.

  1. Access the LUA 2.x server's GUI. Double-click on the LiveUpdate Administrator Icon on the desktop or use your Internet Browser to connect to the web interface. The default login location if accessing from a remote computer is http://<IP_of_LUA_2.x_server>:7070/lua/logon.do  
  2. Log into the LUA 2.x server using your user name and password

NOTE: to add or change distribution options, you must be logged into the LUA 2.x server as an administrator.

Under the Configure tab, click the Distribution Centers tab.

NOTE: the "Default Product Distribution Center" will distribute content via HTTP to a folder local to the LUA 2.x server: If you choose the default install path, content would be distributed to the \Program Files\Symantec\LiveUpdate Administrator\clu-prod folder
 

  1. To add a new Distribution Server, click the Add button
  2. Enter a name for this distribution server. This name will be used as a reference in LUA
  3. Choose to make this a "Test" or "Production" distribution server
  4. Enter a description of the distribution server
  5. Add a location:
    1. Enter the name for the location server
    2. Enter the IP or FQDN of the distribution target
    3. Enter the root directory for the target. If it is the root of the HTTP server for the host name, leave the directory blank
    4. Enter the login id and password for the distribution server (The same username that you created earlier)

      NOTE: if you run into difficulty accessing the distribution server, add the domain or the IP address of the LUA 2.x server before the login account used, seperated by a back slash. Example: if your distribution server you are connecting to is 10.0.0.0, and you are using an account called luadmin, you may need to set the login id to 10.0.0.0\luadmin
       
    5. If the LiveUpdate clients connecting to this server must use a different user id/password to connect and download content, uncheck the "Same as above" check box and enter the user name (login id) and password
    6. Choose the protocol the distribution server is using.

      NOTE: LUA 2.x does not supply the protocol used for by the distribution server to either supply content updates to clients or to receive content updates from the LUA 2.x server
       
    7. If a proxy is used between the LUA 2.x server and the distribution server, enable the Use proxy option and enter in your proxy information
    8. Click the Test button to make sure LUA 2.x can connect to the distribution server
    9. If the test is successful, click OK.
       
  6. Choose the products to send to the distribution server:
    1. Next to the "Product List" heading, click the Add button
    2. This will show a list of products you chose to download under the Configuring Downloads section of this document. Select any LiveUpdate packages/product updates you would like to distribute to this distribution server
    3. After you choose the product updates, click OK
  7. Finish the distribution server setup by clicking Apply then OK


Each time that you update the Symantec Product Catalog on the external server, you need to copy the file SymantecProductCatalog.zip from the external server and put it in the same folder in the internal server, the folder is
%systemdrive%\Documents & Settings\All Users\Application Data\Symantec\LiveUpdate Administrator\Downloads
After that you can update the product catalog on the internal server.

In the internal server you need to create a folder that can be name RecentDownloads share this folder with the defaults permissions and the same name RecentDownloads

Then with the distribution process finished on the external server you need to copy all the content from the folder
%systemdrive%\Program Files\Symantec\LiveUpdate Administrator\clu-prod
and put that content copied from the external server folder to the RecentDownloads folder, the one that was created and shared before.

Then you can configure the download on the internal server and is where the procedure change, during the download definition you need to specify as the source server the localhost and use the UNC instead of a protocol

Configuring the Source Server

  1. Launch the LUA 2.x web interface and log in
  2. Click Configure> Source Server.
  3. Type the following information into the appropriate boxes:
    • Source server name: Local Computer (can be anything)
    • Priority (from 1 to 5): 1 (any)
    • Hostname/IP address: localhost
      • Root directory: RecentDownloads
      • Login id: (IP)\(admin account)
      • Password: (admin password)
      • Confirm password: (admin password)
      • Protocol: UNC (This will gray out the remainder of the form)
  4. Then click Apply


Configuring Downloads

  1. Access the LUA 2.x server's GUI. Double-click on the LiveUpdate Administrator Icon on the desktop or use your Internet Browser to connect to the web interface. The default login location if accessing from a remote computer is http://<IP_of_LUA_2.x_server>:7070/lua/logon.do 
  2. Log into the LUA 2.x server using your user name and password
    NOTE: to add or change download options, you must be logged into the LUA 2.x server as an administrator
  3. Click on the Configure tab
  4. Update your Symantec Product Catalog (SPC) by clicking on "Update Symantec Product Catalog". Once this is complete, move to step 5
  5. To add a new product, click "Add New Products"
  6. Select the products you would like to update.
    1. Click on the "Product Line" you would like to add to LUA 2.x
    2. Under "All Products", choose the versions you would like to update
    3. Once you have finished with selecting the Products for the Product Line selected in step a., click OK
    4. If you would like to add more products, start with Step 5


Configuring Distribution

  1. Access the LUA 2.x server's GUI. Double-click on the LiveUpdate Administrator Icon on the desktop or use your Internet Browser to connect to the web interface. The default login location if accessing from a remote computer is http://<IP_of_LUA_2.x_server>:7070/lua/logon.do   
  2. Log into the LUA 2.x server using your user name and password.

    NOTE: to add or change distribution options, you must be logged into the LUA 2.x server as an administrator
     
  3. Under the Configure tab, click the Distribution Centers tab.

    NOTE: the "Default Product Distribution Center" will distribute content via HTTP to a folder local to the LUA 2.x server: If you choose the default install path, content would be distributed to the \Program Files\Symantec\LiveUpdate Administrator\clu-prod folder
     
  4. To add a new Distribution Server, click the Add button
  5. Enter a name for this distribution server. This name will be used as a reference in LUA
  6. Choose to make this a "Test" or "Production" distribution server
  7. Enter a description of the distribution server
  8. Add a location
    1. Enter the name for the location server
    2. Enter the IP or FQDN of the distribution target
    3. Enter the root directory for the target. If it is the root of the HTTP server for the host name, leave the directory blank
    4. Enter the login id and password for the distribution server (The same username that you created earlier)

      NOTE: if you run into difficulty accessing the distribution server, add the domain or the IP address of the LUA 2.x server before the login account used, seperated by a back slash. Example: if your distribution server you are connecting to is 10.0.0.0, and you are using an account called luadmin, you may need to set the login id to 10.0.0.0\luadmin
       
    5. If the LU clients connecting to this server must use a different user id/password to connect and download content, uncheck the "Same as above" check box and enter the user name (login id) and password
    6. Choose the protocol the distribution server is using.

      NOTE: LUA 2.x does not supply the protocol used for by the distribution server to either supply content updates to clients or to receive content updates from the LUA 2.x server.

       
    7. If a proxy is used between the LUA 2.x server and the distribution server, enable the Use proxy option and enter in your proxy's information
    8. Click the "Test" button to make sure LUA can connect to the distribution server
    9. If the test is successful, click OK.
       
  9. Choose the products to send to the distribution server
    1. Next to the "Product List" heading, click the Add button
    2. This will show a list of products you chose to download under the "Configuring Downloads" section of this document. Select any LiveUpdate packages or product updates you would like to distribute to this distribution server
    3. After you choose the product updates, click OK.

11. Finish the distribution server setup by clicking Apply then OK.

 

Applies To

 

"External server": One LiveUpdate Administrator 2.x server which can access the Internet from a DMZ

"Internal server": One LiveUpdate Administrator 2.x server on a high security network (sometimes called an "airlocked" network) that is completely isolated (no access) from the internet and from the DMZ network

 

(For networks where the Internal server can directly access the External server, please see Configuring LiveUpdate Administrator (LUA) to download updates from another LUA Server)