"No Upgrade Available" message when attempting to upgrade from 8.12 to 8.14 via CDROM.
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"No Upgrade Available" message when attempting to upgrade from 8.12 to 8.14 via CDROM.

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Article ID: 314839

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:

  • Attempting to upgrade Aria Suite lifecycle from 8.12 to 8.14 via CDROM results in a "No Upgrade Available" message.
  • When navigating to Settings -> Product Support Pack -> Check Support Packs Online  PSPack are not listed to be applied.
  • A previous upgrade attempt has been made and no snapshot is available to revert to.
  • The appliance update log /var/log/vmware/cap_am/appliance_update_list_ms.log has an INSTALL_FAILED message similar to:
    Already read 626 bytes of 626
    Status file read : {INSTALL_FAILED <Date&Timestamp> <ID> cap-non-lvm-update 44% Starting to execute post install extension script Failed}
    Writing flow control to socket {"ContentLength":197}
    Writing 197 bytes to socket

or

Already read 622 bytes of 622
Status file read : {INSTALL_FAILED <Date&Timestamp> <ID> cap-non-lvm-update 22% Removing stage path failed } 
Writing flow control to socket {"ContentLength":197}
Writing 197 bytes to socket
  • The installer log /var/log/vmware/capengine/cap-non-lvm-updateinstaller-<<timestamp>>.log has a failure when validating packages:


    error: Failed dependencies:
            eventlog is obsoleted by (installed) syslog-ng-3.37.1-4.ph3.x86_64
    D: closed   db index       /var/lib/rpm/Packages

 

Environment

VMware Aria Suite Lifecycle 8.x

Cause

The issue can occur when there is a previous failed upgrade attempt. The upgrade creates a json file to track the status of the upgrade. Without reverting to a snapshot taken prior to the failed upgrade attempt the json file can prevent future upgrades from proceeding.

Resolution

The issue is pending a resolution.

Workaround:

To workaround the issue:

1. Snapshot the Aria Suite lifecycle appliance.

2. SSH to the Aria Suite lifecycle appliance and login with the root user.

3. Remove the package syslog-ng:
yum remove syslog-ng

4. Delete upgrade_status.json file from the Aria Suite lifecycle appliance:
rm /etc/vmware/cap/cap_am/upgrade_status.json

5. Retry the upgrade.

6. If the preceding steps do not resolve revert to snapshots taken step 1.


Additional Information