SDDC manager can't rotate/update/remediate vRLI admin password after vRLI upgrade to 8.10.0
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SDDC manager can't rotate/update/remediate vRLI admin password after vRLI upgrade to 8.10.0

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Article ID: 318593

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

Symptoms:

- SDDC manager can't rotate/update/remediate vRLI admin password after upgrading vRLI to 8.10.0

- vRLI admin account shows as disconnected in the password management tab after upgrading SDDC to version 4.5

- Checking operationsmanager.log:

 

2022-12-01T12:50:37.476+0000 DEBUG [vcf_om,a40cc4f88c14f5ea,190a] [c.v.v.secure.http.HttpClientService,om-exec-17] Making request: POST https://<vRLI-FQDN>:443/api/v1/sessions

 

2022-12-01T12:50:37.487+0000 DEBUG [vcf_om,a40cc4f88c14f5ea,190a] [c.v.v.secure.http.HttpClientService,om-exec-17] Received response with status: 403 reason: POST ... for request with host: <VRLI-FQDN>, port: 443, isSecure: true, path: /api/v1/sessions, queryParamMap: null, headers: {Accept=application/json, Content-Type=application/json}

 


Environment

Vmware Cloud Foundation 4.5
VMware Cloud Foundation 4.x

Cause

In vRLI 8.10, port 443 was disabled for API access. New API access uses port 9543, i.e.: https://<vRLI-FQDN>:9543/api/v1/sessions and hence VCF 4.5 and lower versions of VCF are not compatible with vRealize Log Insight 8.10 

Refer: https://docs.vmware.com/en/VMware-Cloud-Foundation/4.5/rn/vmware-cloud-foundation-45-release-notes/index.html

Resolution

The issue is resolved in VCF 4.5.1 and VCF 5.0.


Workaround:
No workaround for 4.5.0 and lower versions of VCF

Additional Information

Impact/Risks:

- Customer can't rotate/update/remediate vRLI admin

- vRLI admin shows disconnected in SDDC UI