[VMware Cloud] Alert on Cloud Gateway Appliance- "Cloud Gateway Update Failed: Contact support"
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[VMware Cloud] Alert on Cloud Gateway Appliance- "Cloud Gateway Update Failed: Contact support"

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Article ID: 329569

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

The purpose of this document is to offer some troubleshooting steps which can be used to resolved the update failed alert.

Symptoms:
Customer sees the following banner when logged in to the vCenter Cloud Gateway Appliance:

"Cloud Gateway Update Failed: Contact support"

Cause

There are two main reasons the Appliance will display this alert:

1. Firewall rule blocked for the appliance to connect to the updates server
2. The gateway appliance is up-to-date and the alert is stale.

Resolution

Follow the steps to troubleshoot the issue by SSHing to the appliance deployed at the OnPrem Datacenter:

1. Check the connectivity to the updates site using the following curl command:
curl -v https://vcgw-updates.vmware.com

If the connectivity is down, create an on-prem firewall rule that allows vCGWA to reach https://vcgw-updates.vmware.com/ on port 443. This is mandatory for automatic updates.
Once the connectivity is set up, it takes 5 to 10 minutes for the appliance to trigger an update automatically.

2. Check the status of the update with the following command:

more /etc/applmgmt/appliance/software_update_state.conf

If the value of the state field is STAGE_IN_PROGRESS or INSTALL_IN_PROGRESS, then it means that the update is in progress. Let it complete, this will take some time and will depend on the customer's network speed.

3. If the update on the gateway is in the failed state it would be ok to clean up the failed update state and re-attempt the update.

Before you start, make sure that applmgmt service is able to start by executing below

service-control --restart applmgmt

If the service doesn't start successfully then do not proceed. Contact HLM-SRE.

Below are the steps to clean up the failed update state:

service-control --stop applmgmt
rm /etc/applmgmt/appliance/software_update_state.conf
cat <<EOF > /etc/applmgmt/appliance/software_update_state.conf
{
    "state""UP_TO_DATE"
}
EOF
rm /storage/db/patching.db
rm /storage/core/software-update/stage_install_operation
rm -rf /storage/core/software-update/*
service-control --start applmgmt
 

If the Cleanup of failed update state steps is successful, then the update should start in the next 5 mins. You can check the update status using the below command

more /etc/applmgmt/appliance/software_update_state.conf



Additional Information

Updates to the Gateway Appliance and Component Features (vmware.com)

Impact/Risks:
The Appliance may be unable to update itself, potentially leading to issues with communicating to an SDDC that has been recently upgraded.