"Cannot download VIB" error upgrading to vSphere ESXi 7.0 Update 3, ESXi 7.0 Update 3a & ESXi 7.0 Update 3b using vLCM
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"Cannot download VIB" error upgrading to vSphere ESXi 7.0 Update 3, ESXi 7.0 Update 3a & ESXi 7.0 Update 3b using vLCM

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Article ID: 340445

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • You are attempting to remediate your ESXi  hosts to one of the vSphere versions below
    • vSphere ESXi 7.0 Update 3 
    • vSphere ESXi 7.0 Update 3a
    • vSphere ESXi 7.0 Update 3b
  • Using vLCM / Update Manager fails, with a message similar to: 
Cannot download VIB: ''. This might be because of network issues or the specified VIB does NOT exist or does NOT have a proper 'read' privilege set. Please make sure the specified VIB exists and is accessible from vCenter Server.
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  • In the /var/log/vmware/vmware-updatemgr/vum-server/vmware-vum-server-log4cpp.log file, you will see error similar to:
[2021-03-12 14:29:32:727 'DownloadMgr' 139972188141312 ERROR]  [downloadMgr, 678] Executing download job {139970836824816} throws error: HTTP Error Code: 404
 
Note: The preceding log excerpts are only examples. The date, time, and environmental variables may vary depending on your environment.
 


Environment

VMware vSphere ESXi 7.0.3
VMware vSphere ESXi 7.0.1
VMware vSphere ESXi 7.0.2

Cause

  • This issue occurs due to the removal of the vSphere ESXi depot.zip from the VMware Download Website portal for the versions listed below
    • vSphere ESXi 7.0 Update 3 
    • vSphere ESXi 7.0 Update 3a
    • vSphere ESXi 7.0 Update 3b
  • For more information, please see vSphere 7.0 Update 3, Update 3a & Update 3b - Frequently Asked Questions (FAQ) 
  • vLCM / Update Manager will still have the Metadata for updates as it automatically downloads this. As a result vLCM is showing the versions above as an available upgrade patch.

Resolution



Additional Information

  • Here are the three conditions below listed which your environment may fall under 
    • If deployment of vCenter is after the content pull back there is no-impact
    • If vCenter deployments were done before the pull back and have not remediated U3 specific addons, such customers would hit into “VIB not found issue"
    • If vCenter deployments were done before the pull back and content is being downloaded already into the patch db, then such customers would continue to remediate seamlessly and VMware would continue to support such deployments
    • To get the addons remediation working you will have to reset the Database.
  • If you have configured UMDS for offline patching, patch content continues to persist in the UMDS depot directory even after roll-back and can be patched successfully. It is recommended that you manually remove the binaries/VIBs from the UMDS directory or direct the downloads to the new UMDS directory location to be in-sync with VMware’s online depot. For more information, see How to configure the UMDs download location
  • Stateless boot through Autodeploy will have to update the existing rule to point to the previously release image profile and wait for the updated patch.