vSAN Health Service - vSAN HCL Health – NVMe device can be identified
search cancel

vSAN Health Service - vSAN HCL Health – NVMe device can be identified

book

Article ID: 317844

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

This article explains the vSAN Health – NVMe Device Can Be Identified check which is available as of 7.0 U3c and higher in the vSAN Health Service and provides details on why it might report an error.

Symptoms:
The vSAN Health check, "NVMe device can be identified", is showing an alarm (yellow).

Health warning :

Graphical user interface, text, application, email  Description automatically generated

Environment

VMware vSAN 7.0.x

Cause

Currently, there are vSAN certified NVMe devices sharing the same PCI ID, thus searching by PCI ID only, could result in multiple matched vSAN HCL entries to be found. From vSAN Health Service's perspective, this means that the NVMe device can not be identified (from the vSAN VCG), thus HCL check can not be conducted for the NVMe device.

If it is detected that one NVMe device on a host being used by vSAN has multiple matched HCL entries, this health check will show an alarm (yellow). At the same time, the "NVMe device is VMware certified" will be showing an info status (blue) for the NVMe device.

Resolution

You need  to specify which  NVMe device is currently in use to ensure health check "NVMe device is VMware certified" can work properly through the below steps
  1. Click on "Select Device Model" image.png
  2. Select the exact matching NVMe device listed from the vSAN VCG.image.png
To modify any previous selections, please follow the below steps
  1. Navigate to cluster.
  2. Click on Configure. 
  3. Click on vSAN. 
  4. Click on Disk Management. 
  5. Click on Edit unidentified NVMe devices.image.png




Additional Information

Q: What does the vSAN HCL Health - NVMe device is identifiable do?

This check helps if vSAN Health Service can identify an NVMe device used by vSAN. Here "identify" means finding the exactly matching entry in HCL DB. If it finds multiple matched HCL entries in vSAN VCG, then it is marked  "unidentified". The lookup is performed based on the PCI ID information (Vendor ID, Device ID, SubVendor ID, SubDevice ID), the disk capacity, and the drive product ID.

Q: What does it mean when it is in an error state?

It means that the NVMe device has multiple matching items in the vSAN VCG, so that vSAN health service couldn't identify the exact NVMe device to perform the vSAN HCL check. In this situation, we need the customer to specify what the current in-use NVMe device is, to make sure this health check can work properly, following the below steps:

  1. Click the "select the device model" link to select the exact matching NVMe device listed from the vSAN VCG.
  2. To modify any previous selections, navigate to cluster → configure → vSAN → Disk management, click "Edit unidentified NVMe devices".

Q: How does one troubleshoot and fix the error state?

For more information how to query the information for your storage I/O controller, see the Using Esxcli Commands with vSAN (esxcli vsan debug controller list). For searching the device info on the vSAN VCG, see VMware Compatibility Guide for vSAN. If you still have difficultly determining storage I/O controller information, contact VMware Support to assess the situation fully. For more information, see How to file a Support Request in My VMware (2006985) .