Virtual machines names appear as ds:///vmfs/volumes/datastore/vm_name
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Virtual machines names appear as ds:///vmfs/volumes/datastore/vm_name

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Article ID: 342634

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi VMware vSphere ESXi 6.0 VMware vSphere ESXi 7.0 VMware vCenter Server 6.0 VMware vCenter Server 7.0

Issue/Introduction

This article provides steps to troubleshoot non-cloud-managed VMs which appear as a file path (ds:///vmfs/volumes/datastore/vm_name) instead of the VM name.

For cloud-managed environments, see "ds:///vmfs/volumes/datastore/vm_name" name appears for cloud-managed virtual machines

Symptoms:

  • Non-cloud-managed virtual machines names appear as ds:///vmfs/volumes/datastore/vm_name
  • These virtual machines cannot be managed by vCenter server or ESXi hosts

Environment

VMware vCenter Server 6.5.x
VMware vCenter Server 6.7.x
VMware vCenter Server 7.x
VMware vCenter Server 8.x

VMware vSphere ESXi 6.5.x
VMware vSphere ESXi 6.7.x
VMware vSphere ESXi 7.x
VMware vSphere ESXi 8.x

Cause

The issue occurs where the ESXi host is unable to locate the guest VM's files. Possible causes include:

  • Communication issues between the ESXi host and the storage array
  • Datastore problems or datastore corruption
  • Incorrect storage array configuration
  • Storage array malfunction
  • Corruption of virtual machine files

Resolution

Verify datastore accessibility in the vCenter Server and ESXi host:

  1. Ensure the datastores with the VM's files is accessible to the vCenter Server.
  2. Ensure the datastores with the VM's files is accessible in the ESXi host client.
  3. If the datastores are inaccessible, see Performing a rescan of the storage on an ESX/ESXi host
  4. Reboot the vCenter Server.

If the VM files are not accessible:

  1. Remove affected VMs from the vCenter inventory per Remove VMs or VM Templates from vCenter Server or from the Datastore
  2. Re-register the affected VMs per How to register or add a Virtual Machine (VM) to the vSphere Inventory in vCenter Server
  3. If the virtual machine will not re-register, the descriptor file (*.vmx) may be corrupt. To address the issue:
    1. Create a new VM with the same settings. See Rebuilding the virtual machine's .vmx file from vmware.log
    2. Attach the existing virtual disks to the new VM
    3. If it still doesn't power on, restore the virtual machine from backup, or rebuild the virtual machine

If the datastores are still not accessible:

  1. Troubleshoot the datastore problems.
  2. Restore the VM or rebuild the VM to a healthier datastore.

Additional Information