Virtual machines names appear as ds:///vmfs/volumes/datastore/vm_name
search cancel

Virtual machines names appear as ds:///vmfs/volumes/datastore/vm_name

book

Article ID: 342634

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

This article provides steps to troubleshoot non-cloud-managed VMs which appear as a file path (ds:///vmfs/volumes/datastore/vm_name) instead of the VM name.

For cloud-managed environments, see "ds:///vmfs/volumes/datastore/vm_name" name appears for cloud-managed virtual machines

Symptoms:

  • Non-cloud-managed virtual machine names appear as ds:///vmfs/volumes/datastore/vm_name
  • These virtual machines cannot be managed by vCenter server or ESXi hosts

Cause

The issue occurs where the ESXi host is unable to locate the guest VM's files. Possible causes include:

  • Communication issues between the ESXi host and the storage array
  • Datastore problems or datastore corruption
  • Incorrect storage array configuration
  • Storage array malfunction
  • Corruption of virtual machine files

Resolution

Verify datastore accessibility in the vCenter Server and ESXi host:

  1. Ensure the datastores with the VM's files are accessible to the vCenter Server.
  2. Ensure the datastores with the VM's files are accessible in the ESXi host client.
  3. If the datastores are inaccessible -- Performing a rescan of the storage on an ESX/ESXi host
  4. Reboot the vCenter Server.

If the VM files are not accessible:

  1. Remove affected VMs from the vCenter inventory per Remove VMs or VM Templates from vCenter Server or from the Datastore
  2. Re-register the affected VMs -- How to register or add a Virtual Machine (VM) to the vSphere Inventory in vCenter Server
  3. If the virtual machine will not re-register, the descriptor file (*.vmx) may be corrupt. To address the issue:
    1. Create a new VM with the same settings. -- Rebuilding the virtual machine's .vmx file from vmware.log
    2. Attach the existing virtual disks to the new VM
    3. If it still doesn't power on, restore the virtual machine from backup, or rebuild the virtual machine

If the datastores are still not accessible:

  1. Troubleshoot the datastore problems.
  2. Restore the VM or rebuild the VM to a healthier datastore.


While trying to power on the VM, following errors are reported.

In(05) worker-31882256 - FILE:open error on /vmfs/volumes/Datastore/<VMNAME>/<VMNAME>-flat.vmdk: Invalid argument
In(05) worker-31882256 - AIOGNRC: Failed to open '/vmfs/volumes/Datastore/<VMNAME>/<VMNAME>-flat.vmdk' : Invalid argument (160002) (0x42001).
In(05) worker-31882256 - OBJLIB-FILEBE : FileBEOpen: can't open '/vmfs/volumes/Datastore/<VMNAME>/<VMNAME>-flat.vmdk' : Invalid argument (1441796).
In(05) worker-31882256 - DISKLIB-VMFS  : "/vmfs/volumes/Datastore/<VMNAME>/<VMNAME>-flat.vmdk" : failed to open (Invalid argument): ObjLib_Open failed. Type 3

To resolve the issue, follow the steps below:

  1. Migrate the disk to a new datastore and validate the same. If the issue persists, proceed to next step.
  2. Unmount the datastore by vacating all the VM's from the datastore and run VOMA to correct any physical errors reported on the disk. If the issue persists, Proceed to next step.
  3. Use mv command to initiate the copy and then cancel the task so as to create a new reference of the flat.vmdk file on the new datastore and then delete the fiat file (This step is followed to permanently delete the flat file reference from the storage).
  4. Restore the VM from the Backup

Additional Information