Unable to mount/unmount ISO with error "Connection control operation failed for disk 'sata0:0'" (or 'ide0:0')
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Unable to mount/unmount ISO with error "Connection control operation failed for disk 'sata0:0'" (or 'ide0:0')

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Article ID: 313869

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Updated On:

Products

VMware vSphere ESXi VMware Cloud on AWS VMware vCenter Server

Issue/Introduction

When attempting to mount or unmount an ISO image in the CD/DVD drive of a virtual machine, the following error occurs:

  • Connection control operation failed for disk 'sata0:0'
  • Connection control operation failed for disk 'ide0:0'

 

If attempting to mount the ISO from vCenter Content Library.

  • For a VM the following is experienced.

    • From VC receiving error when trying to mount ISO from content library.

    • From ESX embedded client successfully mounted ISO from datastore that exists on same backing storage.

    • From VC successfully mounted an ISO from a DS on same backing storage (not from content library).

  • Uploaded an ISO to the content library that does not already exist in the CL.

    • Successfully mounted the ISO to same VM.

  • Attempted to download (export) one of the original ISOs existing in the content library that has been failing to mount to VM.

    • Receiving error “a general system error occurred:…the export of library item…cannot find library item…in the storage backing of library…”.

Cause

  • A virtual machine with an active snapshot or a pending disk consolidation retains a lock on its virtual hardware configuration. This prevents changes to the CD/DVD drive settings.
  • If using Content Libraries the actual file has been removed from the backing storage outside of the CL interface.

Resolution

  1. Remove Snapshots: Ensure no snapshots exist for the VM.

  2. Consolidate Disks: Right-click the VM > Snapshots > Consolidate.

  3. Direct Host Management: Log in to the ESXi Host Client (not vCenter) for the host where the VM resides.

  4. Edit Settings:
    • Change the CD/DVD drive type to Client Device.
    • Uncheck Connected and Connect at Power On.
    • Device Mode setting for Passthrough is located under the CD/DVD Drive settings

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If using Content Library.

  1. Export files from CL that are able to be exported, if needed.
  2. Delete CL.
  3. Create new CL.
  4. Upload necessary files to new CL for use.

Additional Information

See also related issues when files are removed outside of Content Library interface.