Usage Meter (UM) is unable to request NSX topology
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Usage Meter (UM) is unable to request NSX topology

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Article ID: 319611

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Updated On:

Products

VMware NSX Networking

Issue/Introduction

Symptoms:
  • Customer receives an email from the Usage Meter with the following text:
Usage Meter is unable to collect data from NSX [nsx host]. Product metering will stop after [x] collections if unresolved.

Reason for the failure: NSX topology cannot be gathered. You can examine the logs for further details.. This will affect report output of monthly usage report, customer usage report and others. Please take action before metering is stopped.


Environment

VMware NSX for vSphere 6.4.x
VMware NSX for vSphere 6.3.x

Cause

  • The NSX API which the UM calls during collections returns XML response containing invalid XML characters.
  • This causes the UM collection of NSX usage to fail.

Resolution

To resolve the issue:
  1. Track down the exact error in the UM log file collector.log. The error will be similar to this one:​​​​
WARN [Collector X] nsx.NsxFeatureDetector: Request failed for Url https://[nsx-host]:443/api/4.0/edges/[edge-id]
WARN [Collector X] nsx.NsxFeatureManager: Unable to request NSX topology for [nsx-host]
java.lang.Exception: Request failed for Url https://[nsx-host]:443/api/4.0/edges/[edge-id]
  1. Execute get request to the failing URL to retrieve the response. You can use curl:

    curl -k --user <nsx_username>:<nsx_password> https://[nsx-host]:443/api/4.0/edges/[edge-id]
  2. Use an XML validator to find the invalid character in the XML response. You can use https://www.w3schools.com/xml/xml_validator.asp. (Invalid XML characters are: "&", "<", ">" and quotes.)
  3. In the NSX Manager, find the object with invalid name. Delete it and then create it anew with a valid name.