VCACCAFE plugin: Unable to retrieve all vRealize Automation items within vRealize Orchestrator client Inventory
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VCACCAFE plugin: Unable to retrieve all vRealize Automation items within vRealize Orchestrator client Inventory

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Article ID: 325903

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Provisioned catalog resources can not be loaded under the "Items" tab in the vCACCAFE plugin. Instead, "Error in plugin" message is shown.
  • The java client has messages similar to:
Could not access HTTP invoker remote service at [https://vrealize-orchestrator-fqdn:443/vco/webremoting/vcofactory.service]
Did not receive successful HTTP response: status code = 504, status message = [Gateway Timed-out]
  • Finder methods for catalog resources are failing.


Environment

VMware vRealize Automation 7.x

Cause

Internal logic flaw causes inconsistency in result metadata.

Resolution


Ensure there are valid backups or snapshots to revert to in case of errors or issues during this process.  This operation needs only be performed once per cluster.  vRealize Orchestrator will replicate the updated plugin to all cluster members.
  • Open vRealize Orchestrator Control Center within a client browser:
https://<vRA-vROApplianceFQDN>:8283/vco-controlcenter/
  • Navigate to Manage Plug-ins > Plugins towards the bottom.
  • Select "Browse" and upload/install the attached version of the plugin from this KB: 011nplugin-vcaccafe-7.6.0-13348097
    • Select "Accept EULA"
    • Click "Install"
  • Control Center will initiate an automatic restart of services to load the new plugin:  Wait for vRealize Orchestrator services to be restart.  This can be monitored from "Orchestrator Cluster Management".
  • Test the loading of Items within the plugin after logging back into the vRO Client.


Attachments

o11nplugin-vcaccafe-7.6.0-13348097 get_app