Error "Appliance (OS) root password is expired " while upgrading vCenter Server Appliance 6.5 or 6.7
search cancel

Error "Appliance (OS) root password is expired " while upgrading vCenter Server Appliance 6.5 or 6.7

book

Article ID: 341143

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
  • Upgrading vCenter Server Appliance 6.5 or 6.7 using the VAMI UI fails with the error:
Appliance (OS) root password is expired or is going to expire soon. Please change the root password before installing an update.
 
Appliance (OS) root password is expired
  • Changing the password from the VAMI fails with the error:
Could not set the password
  • When you run command chage -l root  you get the following output:
Output when running command chage -l root
 
 


Environment

VMware vCenter Server Appliance 6.5.x
VMware vCenter Server Appliance 6.7.x

Cause

  • This issue occurs due to the VAMI not being able to change an expired root password.
  • VAMI is only capable of replacing the root password if it is not expired. Once expired you need to change the root password via CLI.

For similar issues see:

Resolution

To resolve this issue, reset the root password from the vCenter Server Appliance via command line:

The process to reset the root password from the vCenter Server Appliance via command line:

  1. Connect to the vCenter Server Appliance with an SSH session and the root user credentials.
  2. Use the following commands to get to the command prompt:
  • shell.set --enabled true
  • shell
Note:  If you cannot login to the SSH connection using the root password use these steps to change the password How to reset the lost or forgotten root password in vCenter Server Appliance 6.5 & 6.7
  1. Change the root password using the command passwd .
  2. Verify the root account password has been changed using the following command:  chage -l root
  3. In order to prevent this issue from happening again in the future, you could set the root password to never expire at the VAMI page or by running this command: chage -I -1 -m 0 -M 99999 -E -1 root
  4. Reattempt the upgrade again. 

 
If this article didn’t solve your issue:
Ask for help here : Click for VMware Communities


Additional Information


For 7.0U1 and 6.7P03 there are a few changes:
  1. The Root user will be prompted for resetting the password when they try to SSH to the machine if expired or expiring.
  2. You can also login to VAMI using the SSO administrator and reset the root password from there.
  3. Email notification is sent earlier to prevent from having the Root password expired.
  4. An alarm will be triggered in vsphere-ui to notify the user about the password expiry.

For more information, see:

Impact/Risks:
  • VCenter is unable to rotate the Logs based on the fact cron jobs are unable to run.
  • VCenter is unable to be upgraded or patched.