GNU GRUB menu contains slight changes due to a change of operating system from SUSE Linux to Photon OS.
Administrative access to the VMware Live Recovery (VLR) or vSphere Replication appliance management interface (VAMI) is lost.
The following error message appears when attempting to log in to the VAMI: "Cannot complete login due to an incorrect token, user name, or password"
vSphere Replication 8.x
vSphere Replication 9.0, 9.0.0.1, 9.0.1, 9.0.2, 9.0.2.1, 9.0.2.2, 9.0.2.3
VMware Live Site Recovery 9.0, 9.0.1, 9.0.2, 9.0.2.1, 9.0.2.2, 9.0.2.3, 9.0.2.4
VMware Live Recovery 9.0.4, 9.0.5, 9.0.5.1
VCF Protection and Recovery 9.1, 9.1.0.0100, 9.1.0.0200
Root password for vSphere Replication (VR) appliance is not known by the administrator.
vSphere Replication/VLR root password is lost or is locked.
Note:The Photon OS splash screen only appears very briefly, so be quick about it. It is better to use VMware Remote Console rather than the Web Console.
VLSR9.X
init=/bin/bash
Press the F10 key to boot and at the bash command prompt mount the root partition
mount -o remount, rw /
Enter passwd then enter to change the password
passwdNew password: <enter new password>Retype new password: <repeat password>passwd: password updated successfully Note : The above will change only root password, if you need to change admin password need to perform additional steps as below
passwd adminNew password: <enter new password>Retype new password: <repeat password> passwd: password updated successfully
If admin account password is locked, VAMI page for appliance will fail to login,
For product version 8.8 and above you will check and clear the lock with the following command
pam_tally2 -u root ----->If locked run:
/sbin/pam_tally2 -r -u root
pam_tally2 -u admin ----->If locked run:
/sbin/pam_tally2 -r -u adminFor product version 8.8 and VLSR 9.x use the command
faillock --user root ----->If locked run:
/sbin/faillock --user root --reset
faillock --user admin ----->If locked run:
/sbin/faillock --user admin --reset For Product version Protection & Recovery 9.x use the below,
Launch the Web Console for the site recovery appliance.
Log in as the root user.
Execute the following command to check the lock status: faillock --user admin
Reset the lockout counter for the admin account: /sbin/faillock --user admin --reset
Verify the counter is cleared: faillock --user admin
Authenticate to the VAMI using the admin account to confirm access is restored.
4. At the command prompt, unmount the file system using the below command
umount /
5. Reboot the appliance reboot -f
6. After the VLSR appliance reboots, log in with the new root password