When using Guest Introspection and/or 3rd party SVA, VMs power on task from vCenter hang at 0%, 19% or 35%
book
Article ID: 320945
calendar_today
Updated On:
Products
VMware NSX Networking
Issue/Introduction
This article provides information on troubleshooting when a VM fails to power on and Guest Introspection and/or 3rd party SVA is used.
Symptoms:
VMs powered on from vCenter hang at 0%, 19% or 35%.
VMs can be powered on from the ESXi host directly.
DRS is enabled on the cluster.
After disabling DRS on the cluster, VMs power on successfully.
You may see the message "Invoking Prechecks" in the Power On task details.
Restarting EAM may unblock the hung task and the VM power on successfully but newly Powered On VMs hang at 0% or 19%.
With vCenter Trivia log enabled, in the vxpd.log file, you see entries repeated every 30 seconds similar to:
2017-10-24T13:22:31.056+04:00 [12552 verbose 'vmmoVm' opID=D8F8CFAD-0000F632-87-8a-12] [VmMo::PowerOnInt] Client VM /vpx/vm/#10361/ polling for ESX agent VMs ready
Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.
Cause
This issue occurs if DRS is enabled and one of the Agent VM is not marked as ready. If VMware Tools is installed but not running on an Agent VM, vCenter does not receive the heartbeat and does not mark the agent VM as ready which prevent the regular/business VM to power on.
Resolution
To resolve the issue, investigate why the VMware Tools in the Agent VM is not running.
Restart VMware Tools on the Agent VM not marked as ready.