vSAN -- Health Service - Cluster - Disk format version
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vSAN -- Health Service - Cluster - Disk format version

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Article ID: 315550

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Updated On:

Products

VMware vSAN VMware vSAN 7.x VMware vSAN 8.x

Issue/Introduction

This article explains the Cluster - Disk format version check in the vSAN Health Service and provides details about why it might report an error.
 
Example:
vSAN cluster expected format version is X, which is the highest supported format version by any host in the cluster. 
For disk with format version lower than expected version, vSAN on-disk format upgrade is recommended, to support latest vSAN features.
 
 
 

Environment

VMware vSAN (All Versions)

 

Cause

Q: What does the Cluster Health - Disk format version test do?

The test verifies the disk format version of all vSAN disks currently in use, and ensures that all vSAN disks use the highest Disk format version that the vSAN version supports.
 

Q: What does it mean when it is in an error state?

When received as a Yellow Warning (as shown in the Screenshot above):
The Disk format version of one or more vSAN disks are compatible, but out of date.
To get full support of the latest vSAN features, a Disk Format upgrade is recommended (= On-Disk Upgrade).
 
When received as a Red Alert:
This configuration must be fixed immediately.
The Disk format version of one or more vSAN disks is out of date and not compatible with other vSAN disks (= vSAN Hosts running mixed versions of Disk format)
vSAN cannot balance data across the vSAN disks, which can lead to problems, e.g.:
  • Creating and/or powering on VMs
  • Overall vSAN Performance degradation
  • Issues with Maintenance Mode
 

Resolution

Q: How does one troubleshoot and fix the error state?

Regardless if the result is a Yellow Warning or a Red Alert an on-disk format upgrade is required to fix the issue.

This is typically a non-disruptive process providing all disks are healthy and upgrading from version 3 or higher as it's only a metadata upgrade that is occurring. 

Note: Ensure there are NO vSAN Alerts in vSAN health then run the Upgrade Pre-check via vSAN Cluster > Configure > vSAN > Disk Management prior to running the upgrade to ensure the upgrade will be successful.

See Upgrading vSAN Disk Format Using vSphere Client for further details.

Possible error seen when performing Upgrade pre-check:

"General vSAN error. Object(s) f82fe462-####-c1c7-####-3868########, 11843d63-####-02da-####-3868######## are inaccessible in vSAN.". It will not be possible to upgrade disk format version when there are inaccessible vSAN objects.

  1. First resolve the inaccessible vSAN objects issue. See KB vSAN Health Service - Data Health - vSAN Object Health - inaccessible objects
  2. Then upgrade the on disk format version.

Refer to the following KB Understanding vSAN on-disk format versions and compatibility for further details regarding vSAN on-disk format versions and compatibility for each vSAN release.

 


 

Additional Information

Is this upgrade performed at the vSAN Cluster level or the ESXi Host level?

--> At the vSAN Cluster level



Can you upgrade the Disk format version on the vSAN Host one-at-a-time, proceeding to the next vSAN Host only after the previous Upgrade completes?

--> That is not possible.
The Disk Format Upgrade is a vSAN Cluster level upgrade which is automated once started:
It automatically upgrades all vSAN Disk Groups on the Cluster by moving from one Host to the next.