The hp-ams process does not stop when restarting ESXi management agents on HP ProLiant G5, G6 and G7-series servers
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The hp-ams process does not stop when restarting ESXi management agents on HP ProLiant G5, G6 and G7-series servers

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Article ID: 316614

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

 



Symptoms:

When restarting ESXi management agents on HP ProLiant G5, G6 and G7-series servers running versions of HP Agentless Management Service (AMS) prior to 10.1.0 , you experience these symptoms:

  • In the Recent Tasks pane of vCenter Server, you see multiple tasks in the In Progress state
  • Virtual machines that still have a stuck In Progress task are greyed out
  • You are unable to edit the settings on a virtual machine that has a stuck task
  • The host in which the virtual machines reside are running on HP Proliant Gen 5, 6 or 7 hardware
  • When you run the services.sh restart command within the ESXi console, you see this output while stopping the hp-ams service:

    Running hp-ams.sh restart
    ~ # Stopping process ...
    Stopping process ...
    Stopping process ...
    Stopping process ...
    Stopping process ...
    Stopping process ...
    Stopping process ...


Environment

VMware vCenter Server 5.0.x
VMware vCenter Server 5.5.x
VMware vSphere ESXi 5.1
VMware vSphere ESXi 5.5
VMware vCenter Server 5.1.x
VMware vSphere ESXi 5.0

Cause

This issue occurs when you use an older HP Customized VMware image to update any HP ProLiant G5, G6 or G7 servers running VMware ESXi 5.0, 5.1 or 5.5. These models cause the HP Agentless Management Service (AMS), Versions 9.5, 9.6 or 10.0 to make continuous restart attempts and potentially fill up syslog with this message:

root: hp-ams-wd: Detected one or more hpHelper process(es) have stopped running. Restarting...

root: hp-ams stop service...

root: hp-ams-wd: hp-ams start...

root: hp-ams start service...

hpHelper[15106]: hp-ams ver 9.5.0-26: System Product Name is ProLiant BL460c G6.

hpHelper[15106]: hp-ams ver 9.5.0-26: This program will only run on HP ProLiant Gen8 or newer platforms.

 

Currently, HP AMS is only supported on ProLiant Gen8 (or later) hosts.

Resolution

To resolve this issue, remove the hp-ams package from the affected ESXi hosts and replace it with the latest version, 10.1.0 or later. Alternatively, you may reinstall ESXi from the latest HP Customized ESXi Images dated March 2015 or later.
 
To remove the hp-ams package from an ESXi host:
  1. Move the ESXi host in to maintenance mode.
  2. Log in to the ESXi host as root.
  3. Run this command to stop the HP Agentless Management Service:

    /etc/init.d/hp-ams.sh stop

    Note: If it is in the process of stopping, press CTRL+Cto stop the current process.
     
  4. Run this command to remove the the HP Agentless Management Service:

    esxcli software vib remove -n hp-ams
     
  5. Reboot the ESXi host.

To install the latest HP AMS VIB in an existing ESXi installation, follow the instructions in the Existing ESXi installation using esxcli and async driver VIB file paragraph in Installing async drivers on VMware ESXi 5.x and ESXi 6.0.x (2005205).

You can find the HP Agentless Management Service (AMS) Offline Bundle for VMware vSphere 5.5, hp-ams-esxi5.5-bundle-10.1.0-12.zip, dated 30 Mar 2015 at * RECOMMENDED * HP Agentless Management Service Offline Bundle for VMware vSphere 5.5.

 
Note:The preceding links were correct as of August 12, 2015. If you find a link is broken, provide feedback and a VMware employee will update the link.


Additional Information

 
How to download and install async drivers in ESXi 5.x/6.x
HP 製 ProLiant G5、G6、G7 シリーズのサーバ上で ESXi 管理エージェントを再起動しても hp-ams プロセスが停止しない
在 HP ProLiant G5、G6 和 G7 系列服务器上重新启动 ESXi 管理代理后,hp-ams 进程不会停止