“msg.snapshot.error-QUIESCING-ERROR” in vCenter Server
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“msg.snapshot.error-QUIESCING-ERROR” in vCenter Server

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Article ID: 334682

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • Restart the Windows Virtual Disk service if the vCenter Server reports the error An error occurred while saving the snapshot: msg.snapshot.error-QUIESCING-ERROR
  • Creating a quiesced snapshot of a virtual machine fails at 30%.

You experience these additional symptoms:
In the /vmfs/volumes/datastore/Affected_VM/vmware.log file, you see entries similar to:

<YYYY-MM-DD>T<time>.453Z| vcpu-0| I120: Guest: [ debug] [vmvss:vmvss] CVmSnapshotRequestor::Start():865: failed call: m_snapResult = VDSHelper::ForEachVolume(std::vector<std::string>(), da), result = 0x80070422</time>
<YYYY-MM-DD>T<time> </time>.454Z| vcpu-0| I120: Guest: [ warning] [vmsvc:vmbackup] CVmVssRequestor::Initialize failed: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. (0x80070422)
<YYYY-MM-DD>T<time> </time>.454Z| vcpu-0| I120: Guest: [ debug] [vmsvc:vmbackup] *** CVmVssRequestor::Finalize
<YYYY-MM-DD>T<time> </time>.455Z| vcpu-0| I120: Guest: [ debug] [vmvss:vmvss] CVmSnapshotRequestor::WaitForUnregistration():2590: enter
<YYYY-MM-DD>T<time> </time>.455Z| vcpu-0| I120: Guest: [ debug] [vmsvc:vmbackup] *** CVmVssRequestor::SendRequestorError
<YYYY-MM-DD>T<time> </time>.456Z| vcpu-0| I120: Guest: [ debug] [vmsvc:vmbackup] *** VmBackup_SendEvent
<YYYY-MM-DD>T<time> </time>.456Z| vcpu-0| I120: Guest: [ debug] [vmsvc:vmbackup] sending vmbackup event, vmbackup.eventSet req.error 3 The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.
<YYYY-MM-DD>T<time> </time>.456Z| vcpu-0| I120: Msg_Post: Warning
<YYYY-MM-DD>T<time> </time>.456Z| vcpu-0| I120: [msg.snapshot.quiesce.vmerr] The guest OS has reported an error during quiescing.
<YYYY-MM-DD>T<time> </time>.456Z| vcpu-0| I120+ The error code was: 3

<YYYY-MM-DD>T<time> </time>.456Z| vcpu-0| I120+ The error message was: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

<YYYY-MM-DD>T<time> </time>.456Z| vcpu-0| I120: ----------------------------------------
<YYYY-MM-DD>T<time> </time>.462Z| vcpu-0| I120: ToolsBackup: changing quiesce state: STARTED -> ERROR_WAIT
The issue affects Windows Server 2008 SP2. You see log entries similar to:

<YYYY-MM-DD>T<time> </time>.536Z| vcpu-1| I120: [msg.snapshot.quiesce.vmerr] The guest OS has reported an error during quiescing.
<YYYY-MM-DD>T<time> </time>.536Z| vcpu-1| I120+ The error code was: 3
<YYYY-MM-DD>T<time> </time>.536Z| vcpu-1| I120+ The error message was: Quiesce operation aborted
<YYYY-MM-DD>T<time> </time>.542Z| vcpu-1| I120: ToolsBackup: changing quiesce state: STARTED -> ERROR_WAIT
<YYYY-MM-DD>T<time> </time>.583Z| vcpu-1| I120: ToolsBackup: changing quiesce state: ERROR_WAIT -> IDLE
<YYYY-MM-DD>T<time> </time>.713Z| vcpu-1| I120: GuestMsg: Channel 2, Protocol error, state: 0
<YYYY-MM-DD>T<time> </time>.782Z| vcpu-0| I120: GuestMsg: Channel 0, Protocol error, state: 0


Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Cause

This issue can occur when the Virtual Disk service does not start in the Windows guest operating system on the affected virtual machine.

Resolution

To resolve this issue, start the Windows Virtual Disk service:

  1. Log in to the Windows operating system as an Administrator.
  2. Click Start, type services.msc, and press Enter.
  3. Right-click the Virtual Disk service and click Start.
If this does not resolve the issue, disable VMware snapshot provider in the affected virtual machine:
  1. Disable the VMware Snapshot provider service in the guest operating system.
  2. Restart the Volume shadow copy service.



Additional Information