Error: "Reset to device, \Device\RaidPort0, was issued" in the Windows event log
search cancel

Error: "Reset to device, \Device\RaidPort0, was issued" in the Windows event log

book

Article ID: 316553

calendar_today

Updated On: 05-01-2025

Products

VMware vSphere ESXi

Issue/Introduction

When running the LSI_SAS controller in a Windows virtual machine, the following symptoms appear:

  • The Windows event log reports the error:

    Reset to device, \Device\RaidPort0, was issued
     
  • The guest operating system of the Windows virtual machine runs slow where it is functionally unresponsive

Environment

  • VMware vSphere ESXi 6.0
  • VMware vSphere ESXi 6.5
  • VMware vSphere ESXi 6.7
  • VMware vSphere ESXi 7.0

Cause

This is a known issue affecting Windows LSI_SAS inbox driver.

Resolution

This issue is fixed in 1.34.02 and later of the LSI_SAS driver. If your driver is outdated, then:
  1. Download the LSILogic SCSI controller driver.
  2. Use the Search tab to download the LSIMPT adapter driver for your guest operating system at Support Documents and Downloads
  3. Select the appropriate driver from the list.
  4. The downloaded driver zip archive also contains a text file that lists the instructions on how to install the driver during the installation of the Windows operating system.

Workaround

Alternatively, as a workaround configure the virtual machine to use the VMware Paravirtual SCSI driver. For more information, see Configuring disks to use VMware Paravirtual SCSI (PVSCSI) adapters.
 
Note: If the virtual machine is part of a Microsoft Cluster, prior to changing the controller, see Microsoft Clustering on VMware vSphere: Guidelines for supported configurations.

Additional Information