Error: "The vMotion failed because the destination host did not receive data from the source host on the vMotion network"
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Error: "The vMotion failed because the destination host did not receive data from the source host on the vMotion network"

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Article ID: 323392

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

This article provides troubleshooting steps to resolve vMotion connectivity failures encountered during migration attempts.

  • This issue is typically seen when attempting a vMotion migration between two ESXi hosts, and the task fails around **36% (or less)** completion. The failure occurs because a large volume of data is moved, and the destination host does not receive an acknowledgment receipt from the source host on the vMotion network.
  • Network misconfiguration can cause random vMotion failures. In such cases, retrying the vMotion operation may occasionally be successful, but the underlying issue persists.
  • When the issue occurs, the following errors may be seen:

    The vMotion failed because the destination host did not receive data from the source host on the vMotion network. Please check your vMotion network settings and physical network configuration and ensure they are correct.

    T
    he vMotion migrations failed because the ESX hosts were not able to connect over the vMotion network. Check the vMotion network settings and physical network configuration.

Environment

  • VMware vSphere 7.x
  • VMware vSphere 8.x

Cause

Network misconfigurations are typically the cause for these error messages, such as:

  • Inconsistent vMotion VMkernel adapter settings between the source and destination hosts.
  • Mismatched TCP/IP stacks for vMotion. For example, some hosts might be configured with the "default" TCP/IP stack while others use a dedicated "vMotion" stack.

  • Physical switch port for vmnic the vMotion vmkernel is using is not configured to allow the appropriate vlan tagging for vMotion traffic

Resolution

Review the network configuration stack.

  1. Check for IP address conflicts on the vMotion network and if the vmk configuration is correct.

    Note:
    Each host in the cluster should have a vMotion vmkernel with an assigned unique IP address.

  2. Check for IP connectivity and packet loss over the vMotion network. Try having the source host ping (vmkping) the destination host's vMotion vmknic IP address for the duration of the vMotion.

    Example

    vmkping -I vmk# <IP of destination host vMotion vmk>


    where vmk# is the vmkernel number of the vMotion vmkernel on the source host. For more information, see Testing VMkernel network connectivity with the vmkping command.

  3. Check the driver/firmware of the physical adapter used for vMotion.

    Note: If the driver or firmware is not up to date, the vMotions can fail with a "timeout" or "waiting for data" error. For more information, see Determining Network/Storage firmware and driver version in ESXi.

  4. Ensure the ESXi firewall ruleset for vMotion is enabled and that there are no other conflicting rules blocking the traffic.

  5. Check for potential interaction with firewall hardware or software that prevents connectivity between the source and the destination TCP port 8000.

  6. Verify all hosts use the same TCP/IP stack for their vMotion VMkernel adapters (either all vMotion stack or all Default stack).
    • Check via vCenter: Host > Configure > Networking > TCP/IP stacks.




Additional Information

Other Examples

  • Migration [184329483:<mig_id>] failed to connect to remote host <###.###.###.###>: Timeout.

    This error indicates that remote host did not accept the connection within the allowed time limit.
     
  • Migration [-1408237366:<mig_id>] failed to connect to remote host <###.###.###.###>: Connection refused.

    This error indicates that the remote host is explicitly not listening on the vMotion port. The vMotion port is 8000, see also Port requirements for VMware vSphere ESXi

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