Unable to grow or expand a VMFS volume or datastore
search cancel

Unable to grow or expand a VMFS volume or datastore

book

Article ID: 313382

calendar_today

Updated On:

Products

VMware vSphere ESXi VMware vSphere ESXi 7.0 VMware vSphere ESXi 8.0

Issue/Introduction

When trying to grow or expand a VMFS volume by clicking Increase Capacity, no drives are being displayed or not the desired drives are showing up.

Environment

ESXi 7.x
ESXi 8.x
ESXi 9.x

Cause

Potential Causes preventing a successful grow/expansion of the VMFS volume or datastore:

  • To increase the capacity (grow or extend) of a VMFS datastore successfully, ensure that the device has been increased from the backend SAN
  • Once completed, initiate a cluster level rescan to ensure that the Extent Device list contains updated list and then use the Increase option
  • If the device for which size is increased from backend SAN is exposed to multiple hosts in multiple clusters, then cluster level rescan has to be triggered on all the clusters where device is visible
  • Also ensure that the LUN ID is same across all the cluster hosts
  • Please ensure there are no partition on the existing LUNS which are being added to the datastore
  • No drives or not the desired drives are being displayed when clicking Increase Capacity. Reason: Only drives matching the same Disk Sector Format as being used by the affected VMFS Datastore are being displayed. The Disk Sector Format can be checked by running via SSH/Putty:
vdq -q | grep -iE "Name|FormatType"
 
"Name"                : "naa.5505########"       --> VMFS Datastore
"FormatType"    : "512n",
"Name"                : "naa.5505########"       --> Drive which is planned to use for extending the VMFS Datastore
"FormatType"    : "512e",
 
--> In this example we do see that both drives are not having the same Disk Sector Format.
Therefore "naa.889988#####" will not be displayed when clicking Increase Capacity because it cannot be used for extending the datastore.
References: 
vSphere 7.0
 

Resolution

After the cause has been identified and resolved, the Capacity of a VMFS datastore can be expanded via the following ways:

Via vCenter Web Client:
 
  • Initiate a Cluster level rescan (incase the device is shared across multiple hosts/clusters) or on the host (incase of a stand-alone host) so as to force the ESXi host(s) to sync in with the change for the underlying devices expansion.
    If the device for which size is increased from backend SAN is exposed to multiple hosts in multiple clusters, then rescan has to be triggered on all the hosts across the clusters where device is visible.

Rescan steps for Post vSphere ESXi host version 8.0U3 and higher

  • Navigate to Datastore and select Datastore > Click on Hosts > Select all the listed Hosts



  • Then Click on Actions > Rescan Storage

 

Rescan step for vSphere ESXi host version 8.0U2 and older 

  • Navigate to Host and Cluster view >  right Click on Cluster > Click on Storage > Click on Rescan Storage

  • Navigate to the Datastore View and select the Datastore

  • Navigate to Configure > Device Backing and select the Extent Name

  • You should be able to see the Device Details reflecting the update capacity basis the expansion done from the SAN.

Notes

  • In this example, the datastore iscsi1 was configured for 250 GB and the underlying device was expanded to 400 GB. 
    If the underlying device is not reflecting the updated info, attempt a cluster/host level rescan once again so that the fields highlighted in the image above indicate the desired change.

  • If a Cluster level rescan is not done from the vCenter Server level, there are good chances that the vCenter Server might not readily detect the change
    and there would be a disparity in the current space/usage for the datastore in question.

  • VMware recommends that a Cluster level rescan at the vCenter Server level is always followed after any form of expansion being done at the host level.  

Additional Information