Troubleshooting damaged operating system components that can cause conversion failures with VMware Converter
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Troubleshooting damaged operating system components that can cause conversion failures with VMware Converter

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Article ID: 337621

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:
  • Using VMware Converter, you are unable to take a snapshot of a volume.
  • The free disk space or used disk space reported in the New Conversion wizard is incorrect.
  • The conversion may fail almost immediately after clicking Finish in the New Conversion wizard
  • You receive one or more of these errors:
     
    • Failed to take snapshot of the source volume
    • Error opening disk device: Incorrect function (1)
    • Failed to get capacity for \\.\PhysicalDrive0 : error opening disk device: Incorrect function (1)
    • sysimage.fault.OsVersionNotFound
    • Warning: no attached disks were detected.
    • The COM Server with CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} and name SW_PROV cannot be started. [0x80070422]


Environment

VMware vCenter Converter Standalone 4.3.x
VMware vCenter Converter 4.0.x
VMware vCenter Converter Standalone 5.0.x
VMware vCenter Converter 4.1.x
VMware vCenter Converter Standalone 4.0.x
VMware Converter 3.0.x
VMware vCenter Converter 4.2.x

Cause

Damaged operating system components can cause VMware Converter to fail when trying to convert a physical or virtual machine.

Resolution

Windows XP, 2003, 2008

To troubleshoot damaged operating system components that cause a conversion failure in Windows XP, 2003, 2008:

  1. Update the disk controller driver to the latest version.
  2. Confirm that the VMware Converter related services are started on the source operating system.

    To ensure the VMware related services are started:
    1. Open a command prompt. For more information, see Opening a command or shell prompt (1003892).
    2. Run these commands:

      net start vstor2-p2v30 (VMware Converter 3.x only)
      net start vstor2-converter (VMware Converter 4.x only )
      net start vmware-converter (VMware Converter 4.x only)
      net start ufad-p2v
      net start "tcp/ip netbios helper"
      net start swprv
      net start vss

       
    3. Confirm that there are no errors in the system Event Log from these sources: VSS, COM, DCOM, Service Control Manager (SCM), VMware Converter. Check for errors during the time period when the conversion was attempted.

      To view the Event Log, go to Start > Control Panel > Administrative Tools > Event Viewer.
       
    4. Verify that there are no Group Policies (GPOs) in effect that are restricting the Volume Shadow Copy services from running.

      Click Start > Run , type rsop.msc, and press Enter. If you are unsure of the GPOs in place, try removing the source server from the domain. This disables the GPOs from Active Directory.
       
    5. If you are running Windows 2008, ensure that you have installed the hot-fix available to fix issues with VSS. For more information, see the Microsoft Knowledge Base article 2495295.

      Note: The preceding link was correct as of August 31, 2011. If you find the link is broken, provide feedback and a VMware employee will update the link.
       
    6. For Windows 2003, try to re-register the Volume Shadow Copy Services (VSS).

      Caution: Re-registering the components is only valid for Windows 2003. Do not attempt this on Windows 2008, as this operating system is manifest based. Manually registering the components can cause unpredictable results.

      Open a command prompt and run these commands for Windows 2003:

      cd %systemroot%\system32
      net stop vss
      net stop swprv
      regsvr32 ole32.dll
      regsvr32 vss_ps.dll
      vssvc /Register
      regsvr32 /i swprv.dll
      regsvr32 /i eventcls.dll
      regsvr32 es.dll
      regsvr32 stdprov.dll
      regsvr32 vssui.dll
      regsvr32 msxml.dll
      regsvr32 msxml3.dll
      regsvr32 msxml4.dll


      Note: For more information, see Opening a command or shell prompt (1003892).
       
    7. Restart the server.
    8. Verify that the VSS writers are working correctly. Open a command prompt and run the command:

      vssadmin list writers

      Note: For more information, see Opening a command or shell prompt (1003892).

      If you encounter an error, see the Microsoft Knowledge Base article 940184. Then, follow the Microsoft Knowledge Base articles list in the Additional Information section of this article, or contact Microsoft support for further assistance.

      Note: The preceding link was correct as of August 31, 2011. If you find the link is broken, provide feedback and a VMware employee will update the link.

Windows NT and Windows 2000

To troubleshoot damaged operating system components that cause a conversion failure in Windows NT and Windows 2000:

  1. Update the disk controller driver to the latest version. For related information, see Conversion fails on a source running Windows NT with a Dell PERC 3 or 4 disk controller (1001559).
  2. Confirm that the VMware Converter related services are started on the source operating system.

    To ensure the VMware related services are started:
     
    1. Open a command prompt. For more information, see Opening a command or shell prompt (1003892).
    2. Run these commands:

      net start vstor2-p2v30 (VMware Converter 3.x only)
      net start vstor2-converter (VMware Converter 4.x only )
      net start vmware-converter (VMware Converter 4.x only)
      net start ufad-p2v
      net start "tcp/ip netbios helper"
      net start swprv
      net start vss

       
  3. Confirm that there are no errors in the system Event Log. Check for errors during the time period when the conversion was attempted.
     
    • For Windows NT:
      1. Go to Start > Run, type eventvwr, and press Enter.
      2. Check for errors from these sources: RPCSS, COM, DCOM, Service Control Manager, vstor2-p2v30, vstor2-converter, vmware-converter, ufad-p2v.
         
    • For Windows 2000:
      1. Go to Start > Control Panel > Administrative Tools > Event Viewer .
      2. Check for errors from these sources: COM, DCOM, Service Control Manager (SCM), VMware Converter .
         
  4. Restart the source server. This may restore the functionality of certain operating system components.


Additional Information

For related troubleshooting information, see:

Note: The preceding links were correct as of May 13, 2011. If you find a link is broken, provide feedback on the article and a VMware employee will update the article as necessary.

Converting a physical blade server fails
Conversion fails on a source running Windows NT with a Dell PERC 3 or 4 disk controller
Opening a command or shell prompt
Best practices for using and troubleshooting VMware Converter
Troubleshooting when vCenter Converter fails to complete a conversion of a physical or virtual machine
Troubleshooting a vCenter Converter snapshot process that fails to initialize
Conversion fails with the error: Converter unable to create a VSS snapshot of the source volume
オペレーティング システム コンポーネントが破損している場合に VMware Converter での変換に失敗する問題のトラブルシューティング
对可导致 VMware Converter 转换失败的受损操作系统组件进行故障排除