Unable to access IAM CS Management Console
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Unable to access IAM CS Management Console

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Article ID: 5156

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

When trying to access IAM Connector Server Management console (http://JCS_FQDN:20080/main) - a blank page is seen, instead of the expected login page.

JCS stderr log file may have the following exception

Exception in thread "Thread-43" java.lang.Error: CRITICAL: page header magic for block 121 not OK 0
               at jdbm.recman.PageHeader.<init>(PageHeader.java:74)
               at jdbm.recman.PageHeader.getView(PageHeader.java:97)
               at jdbm.recman.PageManager.getNext(PageManager.java:190)
               at jdbm.recman.PageCursor.next(PageCursor.java:92)
               at jdbm.recman.PhysicalRowIdManager.fetch(PhysicalRowIdManager.java:158)
               at jdbm.recman.BaseRecordManager.fetch(BaseRecordManager.java:337)
               at jdbm.recman.CacheRecordManager.fetch(CacheRecordManager.java:263)
               at jdbm.btree.BTree.getRoot(BTree.java:525)
               at jdbm.btree.BTree.find(BTree.java:401)
               at org.apache.directory.server.core.partition.impl.btree.jdbm.JdbmTable.getRaw(JdbmTable.java:1365)
               at org.apache.directory.server.core.partition.impl.btree.jdbm.JdbmTable.get(JdbmTable.java:316)
               at org.apache.directory.server.core.partition.impl.btree.jdbm.JdbmIndex.forwardLookup(JdbmIndex.java:203)
               at org.apache.directory.server.core.partition.impl.btree.jdbm.JdbmPartition.getEntryId(JdbmPartition

Or

jcs_daily.log might show:

ERROR  - Dispatch failed. java.lang.Exception: The management service is not available.

Or 

Event Viewer:

A timeout (30000 milliseconds) was reached while waiting for a transaction response from the im_jcs service.

Environment

Identity Manager - Java Connector Server 12.6 (any SP), 14.2, 14.4, 14.5

Cause

Different causes, on the server side (inconsistent state) as well as client side (browser incompatibility)

Resolution

To restore access to the IAM Connector Server Management Console, please try the following:

1. To eliminate browser related issues (such as security restrictions etc) - try a different browser (FireFox, Chrome) or a different desktop all together. You might want to switch on browser developer mode (F12 - Network tab) to see whether it is able to correctly route to the hostname used in the URL.

2. To eliminate server inconsistent state, try to restart the Java Connector Server (JCS) and once verified it is up and running, try accessing IAM Connector Server Management Console again

3. If previous steps are not helping in gaining access to IAM Connector Server Management Console, the following should be attempted:

- Stop JCS Service
- Delete the following folders
..\Connector Server\Data\activemq
..\Connector Server\data\cache
..\Connector Server\data\derby
..\Connector Server\data\port
..\Connector Server\jcs\data\jdbm\etasa
..\Connector Server\jcs\data\jdbm\SA Configuration
- Start JCS Service

Try accessing IAM Connector Server Management Console again