VMware vCloud DirectorでvCenterから既存のvAppへのVMインポートが"No suitable resource was found"で失敗する
search cancel

VMware vCloud DirectorでvCenterから既存のvAppへのVMインポートが"No suitable resource was found"で失敗する

book

Article ID: 448385

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

免責事項: これは英文の記事 VM Import from vCenter to Existing vApp Fails with "No suitable resource was found" in VMware vCloud Director の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

VMware Cloud Director UIから vCenter の仮想マシン(VM)を既存のvAppにインポートしようとすると、操作が失敗します。この失敗は、システムが使用可能なVMグループおよびデータストアを誤って拒否してしまうために発生します。

  • インポート処理は、UIパスから実行:
    データセンター > vApp > すべてのアクション > vCenter Server から仮想マシンをインポート
  • /opt/vmware/vcloud-director/logs/ ディレクトリ配下にある vcloud-container-info.log ファイルには、ストレージ ポリシーの不一致によってストレージ コンテナが拒否されたことを示す以下のようなエラーが記録されます:
    java.util.concurrent.ExecutionException: com.vmware.vcloud.api.presentation.service.InternalServerErrorException: The operation failed because no suitable resource was found. Out of 8 candidate hubs:
    1 storage containers rejected because: They are not accessible to any ESXi hosts.  Rejected storage containers: <container_name>
    36 storage containers rejected because: They do not support the required storage policy: <Storage_policy_name>.  Rejected storage containers: <Storage_policy_name>
    <Storage_policy_name>, <Storage_policy_name>, <Storage_policy_name>

Environment

VMware vCloud Director 10.6.x

Cause

これは VMware Cloud Director の既知の問題です。インポートされたディスクの詳細情報が、バックエンドのリクエスト ペイロードから省略されることが原因です。

バックエンドがユーザーによって選択されたインポート先ディスクのストレージ ポリシー詳細を受け取れないため、VMのインポート先となる組織仮想データセンター(Org VDC)の標準ストレージ ポリシーが自動的にデフォルトとして適用されます。この不一致により、システムは利用可能なストレージ コンテナが(誤って適用された)要求ポリシーをサポートしていないと判断し、最終的にそれらのストレージ コンテナを評価/拒否してしまいます。

Resolution

この問題は、VMware Cloud Director の将来のリリースで修正される予定です。