免責事項: これは英文の記事 VM Import from vCenter to Existing vApp Fails with "No suitable resource was found" in VMware vCloud Director の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。
VMware Cloud Director UIから vCenter の仮想マシン(VM)を既存のvAppにインポートしようとすると、操作が失敗します。この失敗は、システムが使用可能なVMグループおよびデータストアを誤って拒否してしまうために発生します。
VMware vCloud Director 10.6.x
これは VMware Cloud Director の既知の問題です。インポートされたディスクの詳細情報が、バックエンドのリクエスト ペイロードから省略されることが原因です。
バックエンドがユーザーによって選択されたインポート先ディスクのストレージ ポリシー詳細を受け取れないため、VMのインポート先となる組織仮想データセンター(Org VDC)の標準ストレージ ポリシーが自動的にデフォルトとして適用されます。この不一致により、システムは利用可能なストレージ コンテナが(誤って適用された)要求ポリシーをサポートしていないと判断し、最終的にそれらのストレージ コンテナを評価/拒否してしまいます。
この問題は、VMware Cloud Director の将来のリリースで修正される予定です。