vCenter の収集ステータスが「Unknown」になり、vCenter のログが表示されない
search cancel

vCenter の収集ステータスが「Unknown」になり、vCenter のログが表示されない

book

Article ID: 436069

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

免責事項:これは英文の記事「vCenter Collection Status = Unknown and not seeing vCenter logs(376936)」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

 

Aria Operations for Logs の UI で [統合]  > [vSphere] を開くと、vCenter の収集ステータス が以下のいずれかで表示され、ログが収集されません。

Unknown (不明)

Timeout (タイムアウト)

Collection error (収集エラー)

Environment

VMware Aria Operations for Logs 8.18

Cause

これは既知の問題です。本事象が発生している場合、以下のログファイル

/storage/core/loginsight/var/runtime.log
/storage/core/loginsight/var/plugins/vsphere/li-vsphere.log

に以下のようなエラーメッセージが記録されます。

["ScheduledPluginServiceScheduledTask-thread-2"/10.xx.xx.xx ERROR] [com.vmware.loginsight.scheduled.ScheduledPluginService] [Could not get the connected cluster nodes to reassign vSphere integrations to them]

Resolution

回避策 1:

内部設定ページ (https://<AriaOpsForLogsのIP>/internal/config) にアクセスします。

<distributed> セクション内にある standalone (プライマリノード) の設定箇所で、host= の値を FQDN から IP アドレスに変更 します。

変更前: 
 <distributed overwrite-children="true">
    <daemon host="ariaoperationsforlogs.example.com" port="16520" token="xxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxx">
      <service-group name="standalone" />
    </daemon>
    <daemon host="10.xx.xx.xx" port="16520" token="xxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxx">
      <service-group name="workernode" />
    </daemon>
    <daemon host="10.xx.xx.xx" port="16520" token="xxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxx">
      <service-group name="workernode" />
    </daemon>
  </distributed>

変更後: 
<distributed overwrite-children="true">
    <daemon host="10.xx.xx.xx" port="16520" token="xxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxx">
      <service-group name="standalone" />
    </daemon>
    <daemon host="10.xx.xx.xx" port="16520" token="xxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxx">
      <service-group name="workernode" />
    </daemon>
    <daemon host="10.xx.xx.xx" port="16520" token="xxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxx">
      <service-group name="workernode" />
    </daemon>
</distributed>

vSphere 統合において、認証情報や証明書に問題がなく、UI上からのテスト接続が成功する場合は、SSH から Log Insight サービスを再起動します。
注: クラスタ構成の場合は、必ずプライマリノードから先に実行し、その後ワーカーノードで実行してください。

service loginsight stop
service loginsight start

サービス再起動後、vCenter の収集ステータスが「Collecting (収集中)」に変わることを確認します。

回避策 2:

  • 回避策 1 と同様にプライマリノードの /internal/config ページで FQDN を IP アドレスに変更します。
  • 管理者権限で UI にログインし、[統合] > [vSphere] から影響を受けている vCenter を選択し、一度構成を削除します。
  • 全ノードの Log Insight サービスを停止します(プライマリから順に実施)。
    service loginsight stop
  • 全ノードの Log Insight サービスを開始します(プライマリから順に実施)。
    service loginsight start
  • vCenter を統合画面から再登録します。この際、vCenter の FQDN ではなく IP アドレスを使用して登録してください。
    VMware Aria Operations for Logs と vSphere 環境の接続
  • 収集ステータスが「Collecting」になったことを確認します。