Kubernetes CLI Tools for vSphere and vSphere Plugin Error
search cancel

Kubernetes CLI Tools for vSphere and vSphere Plugin Error

book

Article ID: 424489

calendar_today

Updated On:

Products

VMware vSphere Kubernetes Service

Issue/Introduction

After configuring the kubectl vsphere login attempts fail, regardless of the context specified and the user logging in. 

kubectl vsphere login --server=########### --tanzu-kubernetes-cluster-name <guest cluster name> --tanzu-kubernetes-cluster-namespace <guest cluster namespace> --vsphere-username [email protected] --insecure-skip-tls-verify

error msg="Error occurred during HTTP request: Get \"https://<supervisorIP>/wcp/loginbanner\": dial tcp <supervisorIP>:443: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond."
There was an error when trying to connect to the server. Please check the server URL and try again.

Environment

vSphere Supervisor.

Cause

Port 443 is blocked on environment

Resolution

Open port 443 as per ports

               
Product Version Source Destination Ports Protocols Service Description Classification 
vSphere 8.0, 7.0, 9.0 Management Workstations Supervisor Control Plane Management Network IP
address
443 TCP Expose HTTPS access to the kubectl-plugin-service (to the kubectl-plugin download page).
vSphere - Tanzu
Incoming

 

Additional Information

Notes: