vSphere HA fails - Cannot complete the configuration of the vSphere HA agent on the host. "Applying HA VIBs the cluster encountered a failure". failed installing HA component the host: host-#. An internal error occurred while staging/remediating the host
search cancel

vSphere HA fails - Cannot complete the configuration of the vSphere HA agent on the host. "Applying HA VIBs the cluster encountered a failure". failed installing HA component the host: host-#. An internal error occurred while staging/remediating the host

book

Article ID: 423905

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • While enabling or reconfiguring vSphere HA, the following error is observed in vCenter UI:

    Cannot complete the configuration of the vSphere HA agent on the host. "Applying HA VIBs on the cluster encountered a failure". failed installing HA component on the host: host-####. An internal error occurred while staging/remediating the host.



  • vSphere HA configuration might fail after vCenter patching.

  • The FDM VIB is not updated on the affected ESXi host.

  • Listing datastores on the ESXi CLI fails with an error:

    [root@ESXi_FQDN] df -h
    VmFileSystem: Slow refresh failed: Cannot open volume: /vmfs/volumes/########
    Error when running esxcli, return status was: 1
    Errors:
    Error getting data for filesystem on '/vmfs/volumes/#########' : Cannot open volume: /vmfs/volumes/#########, skipping.

Environment

VMware vCenter Server 8.x

Cause

The issue occurs because the LUN presented to the ESXi host is not in a ready state or has storage inconsistencies, preventing the FDM agent from installing or updating.

Resolution

  1. Rescan the storage adapters on the affected ESXi host to refresh datastore visibility.

    1. Refer to the article: Performing a rescan of the storage on an ESXi host 

  2. Run the df -h command on the ESXi host and verify if the presented datastores are listed.

  3. Once the datastores are listed, perform a reconfiguration of vSphere HA:

    1. Disable vSphere HA at the cluster level.

    2. Re-enable vSphere HA to trigger a fresh HA configuration.

    3. Refer to the article: Disabling and enabling VMware vSphere High Availability (vSphere HA)