What is the process to request the DLP Clean Agent Tool?
search cancel

What is the process to request the DLP Clean Agent Tool?

book

Article ID: 414240

calendar_today

Updated On:

Products

Data Loss Prevention Data Loss Prevention API Detection Data Loss Prevention API Detection for Developer Apps Virtual Appliance Data Loss Prevention Cloud Detection Service Data Loss Prevention Cloud Detection Service for Endpoint Data Loss Prevention Cloud Detection Service for ICAP Data Loss Prevention Cloud Detection Service for REST Data Loss Prevention Cloud Package Data Loss Prevention Cloud Prevent for Microsoft Office 365 Data Loss Prevention Cloud Service for Discovery/Connector Data Loss Prevention Cloud Service for Email Data Loss Prevention Cloud Storage Data Loss Prevention Core Package Data Loss Prevention Data Access Governance Data Loss Prevention Discover Suite Data Loss Prevention Endpoint Discover Data Loss Prevention Endpoint Prevent Data Loss Prevention Enforce Data Loss Prevention Enterprise Suite Data Loss Prevention for Mobile Data Loss Prevention Form Recognition Data Loss Prevention Network Discover Data Loss Prevention Network Monitor Data Loss Prevention Network Monitor and Prevent for Email Data Loss Prevention Network Monitor and Prevent for Email and Web Data Loss Prevention Network Monitor and Prevent for Web Data Loss Prevention Network Prevent for Email Data Loss Prevention Network Prevent for Email Virtual Appliance Data Loss Prevention Network Prevent for Web Virtual Appliance Data Loss Prevention Network Protect Data Loss Prevention Oracle Standard Edition 2 Data Loss Prevention Plus Suite Data Loss Prevention Sensitive Image Recognition

Issue/Introduction

The DLP clean agent tool is a LAST RESORT utility that does a brute force removal of the agent and should only be used as a last resort if all other methods fail

This utility and its instructions are only to be used on one off situations where Broadcom engineering has deemed it necessary to use this tool

Environment

DLP 16.x

Windows Endpoints

Cause

The endpoint agent has been deployed and either will not start, will not uninstall, or is not communicating to the DLP environment

Resolution

Due to the increase of users utilizing the clean agent as a first line of uninstallation, there is a process in place to track and provide the DLP clean agent only when necessary and deemed needed by development

The Admin of the environment will need to work with support to provide the following: 

  • Install logs from a workstation in the down state
  • Uninstall logs from a workstation in the down state
  • A list of the uninstallation efforts that have been attempted and the results of those attempts for that workstation
  • A list of the errors you are seeing in the logs for that workstation
  • What has been done to mitigate the concern

Support will work with development to aid in resolving the uninstall concern and only if development deems it necessary will a version specific DLP clean agent tool will be provided for the computer for which the above data has been provided. 

A reminder, the clean agent tool is a brute force utility and is only to be used as a last resort only