VMware VMware Cloud Foundation Operations Outbound Network Share Plugin is unable to connect to the share
search cancel

VMware VMware Cloud Foundation Operations Outbound Network Share Plugin is unable to connect to the share

book

Article ID: 412836

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

In VCF Operations 9, the Outbound Network Share Plugin is unable to connect to the file shares.

You might see below :

  • Network share plugin test fails

As a result, customers are unable to use any functionality related to Network Share plugin. 

Environment

VCF Operations 9.0

VCF Operations 9.0.1

Cause

Java version has changed in VCF Operations 9.0.

More specifically there is a missing line in analytics.wrapper:

--add-opens java.base/sun.security.provider=ALL-UNNAMED

 

Resolution

Currently there is only following workaround available :

  1. Take a snapshot of VMware Cloud Foundation Operations cluster following 

    Snapshot Creation in VMware Aria Operations

  2. Login into Admin UI and from System Status page, click on Take Cluster Offline
  3. Once all Nodes are Offline, please proceed applying following steps to each node:
    1. Update /usr/lib/vmware-vcops/user/conf/analytics/wrapper.conf file and append the following line at the end of UNNAMED package section (lines # 415 - 427):

                 wrapper.java.additional.sequence_number=--add-exports=java.base/sun.security.provider=ALL-UNNAMED
         
                 replacing sequence_number with next line number depending on last one in the section (i.e. if last line sequence number is 76, use sequence number 77)

     4. From the Admin UI and System Status page, click on Bring Cluster Online
     
5. Before Logging in to the Product UI, please make sure that all nodes in the Admin UI are showing Online