No mails sent after upgrade
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No mails sent after upgrade

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Article ID: 408031

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Updated On:

Products

VMware Smart Assurance Network Observability

Issue/Introduction

Email notifications are not being received by the NCM users.

Error in the Powerup.log under the $VOYENCE_HOME/ncmcore/logs directory:

2025-08-21 10:56:23,838 ERROR [com.powerup.configmgr.integration.transport.javamail.JavaMailTransportStrategy] (Thread-32) Cannot send e-mail to recipient: <user>@<domain>.com
javax.mail.MessagingException: Could not convert socket to TLS
      at com.sun.mail.smtp.SMTPTransport.startTLS(SMTPTransport.java:2155) ~[javax.mail-1.6.2.jar:1.6.2

Environment

NCM - 10.1.x/24.3.x

Cause

mail.smtp.starttls.enable was set to TRUE but ssl trust was not provided. 

Resolution

  1. Login to the CLI of the Application server (AS) or Combination Server (CS) with 'root' access. 
  2. source /etc/voyence.conf to set environmental variable.
  3. Take backup of applicationContext.xml from path $VOYENCE_HOME/ncmcore/webapps/ncm-webapp/WEB-INF/classes/.
  4. Open applicationContext.xml and look for "mail.smtp.starttls.enable"
  5. If value is set to TRUE, add <prop key="mail.smtp.ssl.trust">Provide SMTP server detail</prop>
    Example:

    <prop key="mail.transport.protocol">smtp</prop>
    <prop key="mail.smtp.auth">false</prop>
    <prop key="mail.smtp.host">SMTP_SERVER</prop>
    <prop key="mail.smtp.port">25</prop>
    <prop key="mail.smtp.starttls.enable">true</prop>
    <prop key="mail.smtp.ssl.trust">SMTP_SERVER</prop>
    <prop key="mail.debug">false</prop>

  6. Save and close the file.
  7. Perform a vcmaster restart as service vcmaster restart for NCM 10.1.6 and below or systemctl restart vcmaster for NCM 10.1.8 and above

Perform a job with user emailID and make sure that email is received.  

Additional Information