The memory usage of agent NSX_OPSAGENT on ESXi node <UUID> has reached <kb> kilobytes which is at or above the high threshold value of 80%
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The memory usage of agent NSX_OPSAGENT on ESXi node <UUID> has reached <kb> kilobytes which is at or above the high threshold value of 80%

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Article ID: 406460

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Updated On:

Products

VMware NSX

Issue/Introduction

  • The Agent memory usage alarm is triggering frequently on ESX hosts.
  • The alarm references the OpsAgent.
  • The ESXi host where the alarm is triggering has the following logging that shows MAC to IP binding being frequently updated.

    /var/log/vmmkernel.log
    [Timestamp] In(182) vmkernel: cpu95:2098285)SwSecPortDBDelV4Entry::[nsx@6876 comp="nsx-esx" subcomp="swsec-[ID]Filter  Clearing matching VMI: 0 [MAC] [IP]
    [Timestamp] In(182) vmkernel: cpu95:2098285)SwSecPortDBDelV4Entry::[nsx@6876 comp="nsx-esx" subcomp="swsec-[ID]Filter  Clearing matching VMI: 0 [MAC] [IP]
    [Timestamp] In(182) vmkernel: cpu95:2098285)SwSecPortDBDelV4Entry::[nsx@6876 comp="nsx-esx" subcomp="swsec-[ID]Filter  Clearing matching VMI: 0 [MAC] [IP]
    [Timestamp] In(182) vmkernel: cpu95:2098285)SwSecPortDBDelV4Entry::[nsx@6876 comp="nsx-esx" subcomp="swsec-[ID]Filter  Clearing matching VMI: 0 [MAC] [IP]


Environment

VMware NSX 4.2.x
VMware NSX 9.0

Cause

High frequency of VM IP/MAC updates causes the CCP to publish updates and barrier messages at a high rate. A memory leak in OpsAgent in handling the barrier message causes high memory usage.

Resolution

This is a known issue impacting VMware NSX.

Workaround:

Option 1:
To temporarily resolve the issue restart the OpsAgent on the affected hosts.

     /etc/init.d/nsx-opsagent.

Option 2:
To prevent the issue on the affected versions identify the MAC and IP addresses from vmkernel log that are frequently updating. Investigate if these updates are expected based on application/VM requirements. It may be necessary to change the application/VM configuration to prevent this issue from triggering.