Error while editing or deleting the NSX cloud in AVI load balancer.
book
Article ID: 405645
calendar_today
Updated On:
Feedback
Subscribe
Products
VMware Avi Load Balancer
Show More
Show Less
Issue/Introduction
The NSX cloud is reporting an unhealthy status from the controller.
The AVI controller is returning the error code below while modifying or deleting the NSX cloud.
{"error":"ERR Error running script (call to f_c91c461c4bfb1d868b6d5b901df069e2f80c492a): @user_script:2: user_script:2: bad argument #1 to 'decode' (string expected, got boolean) "}
Cause
The problem arises when the NSX cloud is configured using the automation without providing the necessary credentials.
When the cloud settings are edited, the credentials field is set to 'Not set'.
Resolution
The fix will be in the versions below.
Workaround:
To fix this issue, configure the credentials using the CLI. (The UI will not allow configuring the credentials.)
Steps:-
SSH to the controller.
Run the below command.
[admin:##-##-##-##]: > configure cloud <your_nsxt_cloud_name>
[admin:##-##-##-##]: cloud> nsxt_configuration
[admin:##-##-##-##]: cloud:nsxt_configuration> nsxt_credentials_ref (press Tab button 2 times to list the available credentials, and then select/type the appropriate.)
[admin:##-##-##-##]: cloud:nsxt_configuration> nsxt_credentials_ref <credentials object>
[admin:##-##-##-##]: cloud:nsxt_configuration> save
[admin:##-##-##-##]: cloud> save
Validate the cloud state.
Note: If the issue persists, please contact Broadcom support.
Feedback
thumb_up
Yes
thumb_down
No