NSX Edge shows configuration status as MPA Connectivity Down
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NSX Edge shows configuration status as MPA Connectivity Down

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Article ID: 404627

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Updated On:

Products

VMware NSX

Issue/Introduction

  • On the NSX manager, Edge nodes are in MPA Connectivity Down Configuration state:

  • NSX Edge nodes can ping the NSX Manager.
  • NSX Edge nodes can connect over port 1234 TCP to NSX Manager.
  • Restarting nsx-proxy service on the Edge node does not help.

Environment

VMware NSX

Cause

FQDN of the NSX manager present in the file appliance-info.xml [located at /etc/vmware/nsx] is incorrect.

Following line can be seen in the XML tag <fqdn> </fqdn>

;; communications error to <DNS_Server_IP>#53: timed out

Resolution

To resolve this, perform the following steps:

1. Rename the current appliance-info.xml file using the following command on the affected Edge Node:

mv appliance-info.xml appliance-info.xml.backup

2. Copy the appliance-info.xml from a Good edge node which has correct NSX manager FQDN and paste it on the affected Edge node.

3. Restart nsx-proxy service using the following command:

/etc/init.d/nsx-proxy restart

 

NOTE:

1. In case of NSX manager cluster, check the appliance-info.xml.backup on affected Edge node and note down the UUID of NSX manager where the following tag is available:

<master>true</master>

2. When copying the appliance-info.xml from a good Edge node to affected Edge node, make the XML tag <master> as true for the NSX manager which you noted in the above step. And for rest of NSX Manager nodes, make sure the <master> is set to false.

Additional Information