NSX Scheduled backups do not execute at the scheduled time, but manual backups are successful.
book
Article ID: 402992
calendar_today
Updated On:
Products
VMware NSX
Issue/Introduction
NSX is configured to take scheduled backups are a prescribed interval
The interval passes but no new backups are created
No error messages appear in the NSX interface or NSX Manager logs
Manual backups execute and are successful
Environment
VMware NSX
Cause
The QuartzSetupServiceImpl service is not running on the service's leader node. Without this service running, no scheduled backups will start.
Resolution
Log into any NSX Manager in the cluster as root.
Perform the following two commands to identify which NSX Manager node is the QuartzSetupService Leader:
su admin -c get cluster status verbose | grep -E "Leaders\:|QuartzSetupServiceImpl"
su admin -c get cluster status | grep <UUID returned in previous command>
Reboot the NSX Manager node associated with that ID.
You can also choose to reboot all nodes in the cluster if you wish.
The only Manager that must be rebooted is the Node ID specified by the UUID associate with the server QuartzSetupServiceImpl.
Additional Information
If this is not your issue or does not address your issue, please see KB373896 for additional symptoms related to other issues and additional troubleshooting steps.