Unable to activate features on SSP - No Valid license available banner message seen.
search cancel

Unable to activate features on SSP - No Valid license available banner message seen.

book

Article ID: 390413

calendar_today

Updated On:

Products

VMware vDefend Firewall with Advanced Threat Prevention VMware vDefend Firewall

Issue/Introduction

Problem: Activating features on SSP fails even after adding a valid license.

Symptom: In SSP-UI, under "NSX Managers -> Connectivity Agent -> View Details," Infrastructure Sync and Inventory Sync are in DOWN/Unknown state after onboarding the NSX manager. There would be a banner on the top of the screen saying "No valid license available".

Impact: Features cannot be activated.

Environment

NSX Manager 4.2.1, NSX Manager 4.2.0, SSP 5.0

Cause

During the onboarding of the NSX Manager, the NSX Common agent service listens for changes in the Appliance Info object. In the code that handles changes to the appliance info, we were not stopping the running Common agent service before starting a new thread. This led to stale threads being left behind, causing inconsistent system behavior. As a result, the Infrastructure sync status is displayed as "DOWN" in the SSP UI, preventing the activation of features since the site service requires the Infrastructure sync status to be "UP" for proper functionality.

Log location: /var/log/proton/nsxapi.log


2024-12-02T19:46:00.642Z  WARN CommonAgentDeltaProcessor IdentifiableProxyObjectDao 79821 - [nsx@6876 comp="nsx-manager" level="WARNING" subcomp="manager"] com.vmware.nsx.management.container.exceptions.ConcurrentUpdateException: STREAM_ID = 155d9263-

aaa7-310b-bb61-5390b0703dc5 | CONFLICT_VALUE = java.lang.Error: Unable to find the corresponding key | CONFLICT_KEY_HASH = 7087306353189594295 | CONFLICT_KEY = string_id: "COMMON_DELTASYNC"

| MAP_NAME = 155d9263-aaa7-310b-bb61-5390b0703dc5 | TRANSACTION_ID = 152d1b2a-f9eb-e5d4-6232-0a9ecd0e4ee4 | OFFENDING_ADDRESS = 14949802

2024-12-02T19:46:00.642Z  WARN CommonAgentDeltaProcessor CommonAgentDeltaConfigProducerImpl 79821 NAPP [nsx@6876 comp="nsx-manager" level="WARNING" s2comp="CommonAgent" subcomp="manager"] Caught exception in ScheduledExecutorService.

com.vmware.nsx.management.container.exceptions.ConcurrentUpdateException: Operation failed because of conflicting transaction. Transaction ID: 152d1b2a-f9eb-e5d4-6232-0a9ecd0e4ee4 Address: 14949802

Resolution

Restart PROTON service on all the 3 NSX managers once there is a change in Appliance Info.


This issue is fixed in: NSX 4.2.1.3

Additional Information

If the resolution mentioned in this KB does not address your issue, refer to the Master KB for NSX Onboarding Issues, which lists all known onboarding scenarios, causes, and troubleshooting methods.