The Datastore is inaccessible ( FC iSCSI / Local )
search cancel

The Datastore is inaccessible ( FC iSCSI / Local )

book

Article ID: 385540

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • A VMFS datastore reports 0 bytes of capacity or shows as inaccessible in the vSphere Client. Attempts to access the device return "Input/Output error."

  • No partition table is found on the device when running either:
    esxcli storage core device partition list -d <device naa/t10 id> 
    partedutil getptbl /vmfs/devices/disks/<device naa/t10 id>

  • /var/log/vmkernel.log report commands failing against the device with SCSI code:

    H:0x0 D:0x2 P:0x0 Valid sense data: 0x4 0x44 0x0 

    OR

    H:0x8 D:0x0 P:0x0 

  • /var/log/vmkernel.log may report that the device is All Path Down (APD) state.

    YYYY-MM-DDThh:mm:ss.sssZ cpu5:2100142)HPP: HppIsDeviceAPD:4979: APD detected for HPP device "naa.xxx".
    YYYY-MM-DDThh:mm:ss.sssZ cpu5:2100142)WARNING: HPP: HppDeviceUpdateState:5032: Device 'naa.xxx' is changing to 'APD' from 'on'.
    YYYY-MM-DDThh:mm:ss.sssZ cpu5:2100142)WARNING: NvmeScsi: 145: SCSI opcode 0x0 (0x45b8e0efd800) on path vmhbaX:CX:TX:LX to namespace naa.xxx failed with NVMe host error
    YYYY-MM-DDThh:mm:ss.sssZ cpu5:2100142)WARNING: status: 0xe translating to SCSI error H:0x1
  • The vmkernel.log contains entries similar to: 
    YYYY-MM-DDThh:mm:ss.sssZ cpu5:2100142)WARNING: ScsiDeviceIO: 12155: READ CAPACITY on device "naa.xxx" from Plugin "HPP" failed. I/O error
    YYYY-MM-DDThh:mm:ss.sssZ cpu5:2100142)WARNING: ScsiDeviceIO: 12155: READ CAPACITY on device "naa.xxx" from Plugin "HPP" failed. I/O error

Environment

VMware vSphere ESXi 7.0.x
VMware vSphere ESXi 8.0.x

Cause

  • SCSI code H:0x0 D:0x2 P:0x0 Valid sense data: 0x4 0x44 0x0 indicates a hardware error reported on the device:
          D:0x2 => Storage Check Condition 
          Valid sense data: 0x4 0x44 0x0 => hardware error, internal target failure

  • H:0x8 => This status is returned when the HBA driver has aborted the I/O. It can also occur if the HBA does a reset of the target.

  • SCSI code H:0x1 indicates the ESXi host is lost connection to the LUN. The LUN is no longer visible to the host.

Resolution

  •  If the device is a local disk, engage the hardware vendor to investigate further.

  •  If the device is an FC or iSCSI disk, engage the storage vendor to investigate further.

Additional Information