Plan Patching/Plan Upgrading screen does not populate in SDDC Manager 5.2.1
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Plan Patching/Plan Upgrading screen does not populate in SDDC Manager 5.2.1

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Article ID: 380402

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Updated On:

Products

VMware Cloud Foundation 5.x

Issue/Introduction

  • When selecting either the 'Plan Upgrade' or the 'Plan Patching' option, the upgrade/patch plan does not load. 

 

  • The following error may be observed in the /var/log/vmware/vcf/lcm/lcm-debug.log file:

    xxxx-xx-xxxxx:xx:xx.xxx+xxxx INFO  [vcf_lcm,] [c.v.e.s.l.p.i.v.rdu.RduClientImpl,http-nio-127.0.0.1-7400-exec-8] Check whether target version 6.7.0-19300125 is compatible with minimum supported target version 8.0.3.00200
    xxxx-xx-xxxxx:xx:xx.xxx+xxxx ERROR [vcf_lcm,d127f08f9d0f48fe,59f0] [c.v.v.l.r.a.c.v.u.UpgradableController,http-nio-127.0.0.1-7400-exec-8] Get SupportedUpgradeMechanisms for vCenter Failed with exception java.lang.RuntimeException: Versions are not in proper format - X.Y.Z.UPPHH-<Build Number>
     
    Note: This issue can occur even if this entry is not logged in the lcm-debug.log file.

Environment

VMware Cloud Foundation 5.2.1

Cause

Stale 6.5 and/or 6.7 vCenter bundle references in the LCM database. 

Resolution

Please implement the following steps to resolve the issue:

1. SSH into the SDDC manager appliance with the vcf user and elevate to root with su

2. Copy the cleanup_vc_bundles_lt7.py script from this KB to the /home/vcf/ directory of the SDDC manager

3. Run the cleanup_vc_bundles_lt7.py with the command below (The script will cycle the lcm service)

python cleanup_vc_bundles_lt7.py

4. After an ample amount of time, retry the Plan Upgrade/Patching workflow in the SDDC Manager UI. 
(It may take 10-15 minutes for the screen to populate)

Additional Information

The issue has been fixed in SDDC version 5.2.1.1.

Attachments

cleanup_vc_bundles_lt7.py get_app