Host status 'unknown' in vLCM
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Host status 'unknown' in vLCM

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Article ID: 379607

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Updated On:

Products

VMware vSphere ESXi VMware vCenter Server

Issue/Introduction

  • Scenario 1:
    • The ESXi host status is showing as 'unknown' after remediation:

ACTIONS ⇓

? Host status is unknown
Info: The host will be rebooted during remediation.
Info: Quick Boot is supported on the host.

Firmware compliance

  • Scenario 2:
    • Or the ESXi host stops part-way through remediation and produces the error:

Host status is unknown

The host could not be reached, and its image compliance could not be checked. Try refreshing image compliance again - the host may be reached successfully.

During remediation, this host may get remediated if it can be reached successfully.

Environment

VMware vSphere Esxi 7.x

VMware vSphere Esxi 8.x

VMware vCenter Server 7.x

VMware vCenter Server 8.x

Cause

Communication issues between the ESXi host and the vCenter/vLCM application.

Resolution

  • Resolution 1
  • Resolution 2
    • Initially try doing a disconnect & reconnect the ESXi host in vCenter Inventory.
    • If that doesn't resolve the issue, gracefully reboot ESXi host.
  • Resolution 3
    • Ensure connectivity from ESXi to VC over port 9084. This port is needed for ESXi to be able to download files from VC through LifeCycle Manager.
    • To test for connectivity from ESXi targeting vCenter:
      • nc -zv <VC_IP> 9084
    • Please see VMware Ports and Protocols under vSphere Product for more information