After upgrading to NSX 4.2.0, LDAP users are unable to view the VIP in NSX Manager
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After upgrading to NSX 4.2.0, LDAP users are unable to view the VIP in NSX Manager

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Article ID: 378717

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Updated On:

Products

VMware NSX

Issue/Introduction

After upgrade to NSX 4.2.0, LDAP users assigned the Enterprise Admin role are encountering several issues, which are not affecting the local admin account:

1. VIP Visibility: LDAP users are unable to view the VIP in the NSX Manager UI under System > Configuration > Appliances > NSX Manager.

2. Backup & Restore Access: LDAP users cannot access the Backup & Restore page under NSX Manager UI > Lifecycle Management, receiving the following error message:

Error: User is not authorized to perform this operation on the application. Please contact the system administrator to get access. (Error code: 401)

3. Support Bundle Generation: LDAP users are unable to generate a support bundle after clicking “START BUNDLE COLLECTION” in NSX Manager UI > Settings > Support Bundle > Request Bundle. The following notification is displayed:

Support bundle request failed: User is not authorized to perform this operation on the application. Please contact the system administrator to get access.
 

Environment

VMware NSX

Cause

This issue arises because when a group name is passed to NAPI, it ignores case sensitivity (upper-case, lower-case, or mixed) and only processes group names in lowercase.

Resolution

This issue has been resolved in version 4.2.1 or higher. For assistance with a workaround, please reach out to Broadcom Technical Support.