Unable to put the host in maintenance mode'./var/log/vmware/vmware-updatemgr/vum-server/vmware-vum-server.log file on the vCenter Server displays the following entry:Host host-<id> could not go into maintenance mode for following reason : Virtual machine 'Z-VRA-<machine-name> on host '<host-name>' would violate a virtual machine - host affinity ruleVMware vSphere ESXi 8.x
VMware vCenter Server 8.x
This issue occurs because Zerto virtual machines are configured with "must run" affinity rules. While manually placing a host into maintenance mode automatically shuts down the Zerto virtual machines, cluster-level vLCM remediation fails because the process cannot migrate or automatically power off these virtual machines.
Choose one of the following methods:
Method 1:
Manually power off the Zerto virtual machines on every ESXi host.
Method 2:
Manually power off the Zerto Site (Note: Validate with Zerto support before executing this step).