Error: "Unable to put host in maintenance mode" during cluster remediation
search cancel

Error: "Unable to put host in maintenance mode" during cluster remediation

book

Article ID: 374379

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • The cluster remediation task fails with the error: 'Unable to put the host in maintenance mode'.

  • The /var/log/vmware/vmware-updatemgr/vum-server/vmware-vum-server.log file on the vCenter Server displays the following entry:

    Host host-<id> could not go into maintenance mode for following reason : Virtual machine 'Z-VRA-<machine-name> on host '<host-name>' would violate a virtual machine - host affinity rule

  • The affinity rules are set on every ESXi host, and Zerto virtual machines are pinned to the ESXi hosts in the cluster.

Environment

VMware vSphere ESXi 8.x
VMware vCenter Server 8.x

Cause

This issue occurs because Zerto virtual machines are configured with "must run" affinity rules. While manually placing a host into maintenance mode automatically shuts down the Zerto virtual machines, cluster-level vLCM remediation fails because the process cannot migrate or automatically power off these virtual machines.

Resolution

Choose one of the following methods:

Method 1:

  • Manually power off the Zerto virtual machines on every ESXi host.

Method 2: