pgService backup files filling disk space leading to vIDM/Aria Automation instability
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pgService backup files filling disk space leading to vIDM/Aria Automation instability

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Article ID: 372820

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • vIDM directory user's are unable to login
  • Aria Automation is down

Environment

  • Aria Automation 8.18.x
  • VMware Identity Manager 3.3.7

Cause

When the VMware Identity Manager Cluster Auto-Recovery feature is active, it generates excessive pgservice.log.backup files in /var/log/pgService. This exhausts the available space in the root directory, may lead to a Postgres Service failure.

Resolution

Please create a valid Backup/Snapshot before deleting any files.

  1. Manually delete old pgService.log.backup files in /var/log/pgService
  2. Create a cron job using crontab for regular clean up:

    • Open the crontab editor with command: 
      crontab -e
    • add a new cronjob to remove backup files, below example removes *.backup files on the 1st day of every month at 3AM
      0 3 1 * * /usr/bin/rm -f /var/log/pgService/*.backup >/dev/null 2>&1

Additional Information

vIDM is down impacting Aria Automation availability. Postgres service is down on master VIDM node.