Purpose: To inform users that the status of this load balancer virtual server is down.
Impact: All the traffic to this virtual server is broken.
Environment
VMware NSX-T Datacenter VMware NSX
Cause
The pool status of this virtual server is down.
Resolution
Steps to resolve For 3.0.0 and higher
Recommendation Action:
Consult the load balancer pool to determine its status and verify its configuration.
If the pool member VM's reported down, validate the VM active status from vCenter and make sure the pool member is active and functioning.
If incorrectly configured, reconfigure it and remove the load balancer pool from the virtual server then re-add it to the virtual server again.
Maintenance window required for remediation? Optional.
Additional Information
If the above checks or solutions do not resolve the issue, please follow the steps below to collect the necessary NSX Edge logs and contact Support with a support case:
When the alarm is triggered, enable debug-level logging for the affected NSX Load Balancer by modifying the respective load balancer configuration and changing the log level from Info to Debug. Additionally, enable access logging on the specific virtual server to capture detailed activity.
"Enabling Debug-level Logging": Login to NSX manager UI using admin account > Networking >Load Balancing >Load Balancers > (Choose the impacted load balancer) edit it using 3 dots >log level > select Debug >click on Save.
"Enabling Access Log": NSX UI >Networking >Load Balancing >Virtual Servers > (Choose the impacted victual server) edit it using 3 dots >Enable "Access Log" >click on Save.
Collect the edge logs as soon as possible. After collecting the required NSX Edge logs, disable the access logs on the virtual server and revert the Load Balancer log level from Debug back to Info without fail.Leaving debug logging enabled for an extended period can impact Edge performance and may eventually cause the Edge to go down.