Error: "Cannot delete network pool {Network Pool Name}. it's in use currently, has networks" when attempting to remove a Network Pool
search cancel

Error: "Cannot delete network pool {Network Pool Name}. it's in use currently, has networks" when attempting to remove a Network Pool

book

Article ID: 320463

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Attempting to remove a Network pool the following error is displayed:

    Cannot delete Network Pool : name: Example-VXLAN-NP , Id: urn:uuid:1<NetworkPool_UUID> , Description :. Its in use currently, has networks:
    [[ Name: Network_name_1, id: urn:uuid :< Network_UUID_1>, deployState: null ] :
    [ Name: Network_name_2, id: urn:uuid: <Network_UUID_2>, deployState: null ] :
    [ Name: Network_name_3, id: urn:uuid: <Network_UUID_3>, deployState: null ] :
    [ Name: Network_name_4, id: urn :< Network_UUID_4>, deployState: null ] :
    [ Name: Network_name_5, id: urn: uuid: <Network_UUID_5>, deployState: null ]

  • Within the log file /opt/vmware/vcloud-director/log/vcloud-container-debug.log the following is observed.

    YYY-MM-DD 10:55:05,936 | DEBUG    | task-service-activity-pool-268 | CJob                           | updateFailedJob(com.vmware.vcloud.api.presentation.service.BadRequestException) with locale=en_US | requestId=<requestid>,request=DELETE https://vcloud.example.com/cloudapi/1.0.0/networkPools/urn:vcloud:networkpool:<network-pool-id>,requestTime=1772445304697,remoteAddress=<ip-address>:60606,userAgent=Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:148.0) Gecko/201...,accept=application/json;version 40.0.0-alpha vcd=<vcd-id>,task=<task-id> activity=(com.vmware.vcloud.backendbase.management.system.TaskActivity,urn:uuid:<uuid>)
    com.vmware.vcloud.api.presentation.service.BadRequestException: Cannot delete Network Pool : name:<network-pool-name> , Id:urn:uuid:<uuid> , Description:. Its in use currently, has networks: [[ Name: dvs.<dvs-id>, id: urn:uuid:<uuid>, deployState: null ] : [ Name: dvs.<network_name>, id: urn:uuid:<uuid>, deployState: null ] : [ Name: dvs.<network_name>, id: urn:uuid:<uuid>, deployState: null ] : [ Name: dvs.<network_name>, id: urn:uuid:<uuid>, deployState: null ] : ].
            at com.vmware.vcloud.fabric.net.impl.RealNetworkPoolFactoryImpl.delete(RealNetworkPoolFactoryImpl.java:305)
            at com.vmware.vcloud.fabric.net.impl.DefaultVxlanNetworkPool.delete(DefaultVxlanNetworkPool.java:559)
            at com.vmware.vcloud.net.impl.HFNetworkPoolManagerImpl.removeNetworkPool(HFNetworkPoolManagerImpl.java:192)
            at com.vmware.vcloud.net.impl.NetworkPoolManagerProxy.removeNetworkPool(NetworkPoolManagerProxy.java:140)
            at com.vmware.vcloud.management.system.NetworkServiceImpl.deleteNetworkPoolTask(NetworkServiceImpl.java:1448)

Environment

VMware Cloud Director 10.6.x

Cause

This issue occurs when Cloud Director believes there are Networks still deployed which are consuming the Network Pool.

Resolution

  1. Open an SSH session to the Cloud Director database cell and login as root.
  2. Connect to the Cloud Director Database using the command:

    db

  3. Run the following to see what is mapped to the Network Pool.

    select
    real_network.id as real_network_id,
    real_network_backing.id as real_network_backing_id,
    logical_network.id as Logical_Network_id,
    logical_network. scope_type as logical_network_type,
    logical_network.name as logical_network_name,
    vmc.name as vApp,
    ovdc.name as VDC
    from network_pool
    left join real_network on real_network.pool_id = network_pool.id
    left join real_network_backing on real_network_backing.rnet_id = real_network.id
    left join logical_network on logical_network.rnet_id = real_network.id
    left join vapp_logical_resource vapplr on vapplr. fo_id = logical_network.id
    left join vm_container vmc on vmc.sg_id = vapplr.vapp_id
    left join org_prov_vdc ovdc on ovdc.id = vmc.org_vdc_id
    where network_pool.name ='<network pool>';

  4. If there are references for vApp, you will need to remove these from the UI.
  5. When there are no vApps listed, attempt to remove the Network Pool from the UI.
  6. If you have removed all vApps and it is still failing, please contact Broadcom Support