VMware High Availability cluster reports the error: "vSphere HA agent on this host could not reach isolation address <IP Address>"
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VMware High Availability cluster reports the error: "vSphere HA agent on this host could not reach isolation address <IP Address>"

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Article ID: 318889

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

In the vCenter user interface, in the Hosts and Clusters view, with the ESXi host selected, you see the message "vSphere HA agent on this host could not reach isolation address <IP Address>

 

 

Environment

VMware ESXi 7.x
VMware ESXi 8.x
VMware vCenter Server 7.x
VMware vCenter Server 8.x

Cause

On a regular basis HA contacts ( using ICMP ping ) its isolation response address to ensure the cluster is functioning correctly. The default isolation response address is the default gateway but other reliable IP addresses can be configured along with the default gateway or the default gateway can also be disabled as an isolation response address.


This issue can occur when HA does not receive a response from all of its configured isolation response addresses.

Resolution

To resolve this issue, investigate your network to determine why HA is unable to receive a response from at least one isolation response address.

  • Verify network connectivity is possible from the host.  It may be necessary to check connectivity to the isolation address from a specific VMkewrnel Adapter.  This may vary from in individual customer environments   
  • From host CLI confirm network Connectivity to the host from VMK adapter
    • vmkping -I vmk<#> <Isolation_Address>



Note:

  • If the isolation response address was manually added using the advanced setting das.isolationaddress remove the non-pingable isolation address from your advanced settings and specify a new pingable isolation address.
  • When the listed ip address is the currently configured default gateway, add an additional isolation address using das.isolationaddress and disable the use of the default gateway for isolation verification using the advanced setting das.usedefaultisolationaddress set to false.

Additional Information

For more information on using CLI command: vmkping, please reference the following article: Troubleshooting network and TCP/UDP port connectivity issues on Hosts

After confirming network connectivity is possible to the Isolation address from the hosts vmk interface and the error message is still presenting on the ESXi host, please proceed with verifying: vSphere HA agent on this host could not reach isolation address '#.#.#.#', reported on ESXi host