Clear VAMI Backup History
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Clear VAMI Backup History

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Article ID: 316489

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

  • vCenter Server Appliance backup progress not available on the VAMI page after upgrading to vSphere 6.7 Update 1
  • The backup operation is successful and the progress is available in the file '/var/log/vmware/applmgmt/backupRestoreProgress.log'
  • The backup files on the target location are consistent
  • You wish to clear the VAMI backup history



Environment

VMware vCenter Server Appliance 6.7.x

VMware vCenter Server 7.x 

VMware vCenter Server 8.x 

 

Cause

The related 6.7 U1 issue occurs if the '/storage/applmgmt/backup_restore/backup_schedule.json' or '/storage/applmgmt/backup_restore/backup-history.json' file has Non-ASCII characters

Resolution

  1. Power-off the vCenter and take a Snapshot of it from the Host GUI it resides on.
  2. Power the vCenter back on
  3. Log in to the vCenter Server Appliance using SSH
  4. Navigate to the location: /storage/applmgmt/backup_restore
    • cd /storage/applmgmt/backup_restore
  5. Rename 'backup-history.json' and 'backup_schedule.json' to a different location
    • mv backup-history.json backup-history.json.old
    • mv backup_schedule.json backup_schedule.json.old
  6. Reconfigure the backup schedule using VAMI.