Cannot change the vCenter Server or Platform Service Controller 6.x hostname on versions prior to vCenter Server 6.7 Update 3
search cancel

Cannot change the vCenter Server or Platform Service Controller 6.x hostname on versions prior to vCenter Server 6.7 Update 3

book

Article ID: 316436

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

vCenter Server 6.x versions prior to 6.7 Update 3 does not support changing the PNID after deployment.

  • The vCenter Server or PSC services fails to start when the IP address or hostname is changed in vCenter Server or Platform Service Controller (PSC).
  • PSC - vmware-sts-idmd.log

    [YYYY-MM-DDTHH:MM:SS] vsphere.local 47c25a86-20c3-49c6-9ec0-c5579b36c83d ERROR] [IdentityManager] Failed to authenticate principal [Administrator@domain] for tenant [vsphere.local]
    com.vmware.identity.idm.IDMLoginException: Access denied
     
  • vCenter - /var/log/vmware/vpxd/vpxd.log

    [YYYY-MM-DDTHH:MM:SS] warning vpxd[03740] [Originator@6876 sub=Default] Failed to connect socket; <io_obj p:0x000000000c4d83d8, h:3392, <TCP '0.0.0.0:0'>, <TCP '</font>IP_Address'>>, e: system:10060(A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond)

    [YYYY-MM-DDTHH:MM:SS] error vpxd[03740] [Originator@6876 sub=HttpConnectionPool-000011] [ConnectComplete] Connect failed to <cs p:0000000008d2dda0, TCP:</font>vcenter.example.com:443>; cnx: (null), error: class Vmacore::SystemException(A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond)

If the hostname and DNS configuration reverts to original values after rebooting the VCSA machine, refer to: VMware vCenter Server Appliance hostname and DNS configuration revert after a reboot  and How to update content libraries after changing vCenter Server PNID

Environment

VMware vCenter Server 6.x

Cause

During the initial configuration of the VMware vCenter Server, the system name (FQDN or IP address) is used as the Primary Network Identifier (PNID). This issue occurs when the PNID of the vCenter Server or PSC is changed after deployment.

Resolution

The PNID is equal to the System Name parameter input during deployment. The System Name can either be a Fully Qualified Domain Name (FQDN) or an IP address. For example, a system name could be vcenter.example.com or ###.###.###.### which would also then become the PNID.
 

Prior to vCenter 6.7 Update 3

For versions prior to vCenter 6.7 Update 3, the PNID is locked in and cannot be changed after deployment. Changing the PNID is not supported in versions prior to 6.7 Update 3. 

Options to resolve the above issue:

  • Revert to a snapshot or an available backup which was created before changing the IP address or hostname.
  • Redeploy the vSphere environment.

After vCenter 6.7 Update 3

Beginning with vCenter Server 6.7 Update 3, the ability to modify the PNID after deployment is available. Refer to Technical Blog: Changing your vCenter Server’s FQDN for more info.

To change the IP address of vCenter Server that was deployed with a FQDN PNID:

Verifying the PNID

To verify the current PNID, run the following command:

/usr/lib/vmware-vmafd/bin/vmafd-cli get-pnid --server-name localhost

Workaround

Note: On rare occasions should the above UI workflows fail to completely set the PNID, manually set and complete the PNID change.

/usr/lib/vmware-vmafd/bin/vmafd-cli set-pnid --server-name localhost --pnid <PNID-NAME>

Warning: Attempting to set the PNID via the command line only without going through the proper workflow, as mentioned in the Resolution section, may break vCenter.