ESXi RAM disk full due to a locked virtual machine log file
search cancel

ESXi RAM disk full due to a locked virtual machine log file

book

Article ID: 306892

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • You are unable to power on a virtual machine.
  • You are unable to register a virtual machine.
  • Virtual machine migrations fail.
  • The vmkernel.log file (located at /var/log/) contains an entry similar to:

    VisorFSRam: 233: Cannot extend visorfs file /var/lib/vmware/hostd/journal/ because its ramdisk (root) is full.

  • The /tmp/vmware-root directory contains a vmware-vmx-xxx.log file that is large in size.
  • The vmware-vmx-xxx.log file (located at /tmp/vmware-root/) cannot be deleted.


Environment

VMware vSphere ESXi 5.1
VMware vSphere ESXi 5.0

Cause

This issue occurs because the vmware-vmx-xxx.log file fails to move to the working directory of the virtual machine. This file cannot be deleted because the virtual machine is running and is writing to the file.

Resolution

To resolve this issue, identify the virtual machine that is locking the vmware-vmx-xxx.log file, release the lock and delete the log file.

To identify the affected virtual machine:
  1. Log in to the ESXi host as the root user.
  2. Run the command:

    grep "Config file:" /tmp/vmware-root/vmware-vmx-xxx.log

    Where xxx is the log file number.

    You see output similar to:

    T08:32:05.463Z| vmx| Config file: /vmfs/volumes/4f55f70a-0bcd954f-d11c-001ec9cf1972/MyVM/MyVM.vmx

  3. To obtain the virtual machine display name, run the command:

    grep displayName /vmfs/volumes/4f55f70a-0bcd954f-d11c-001ec9cf1972/MyVM/MyVM.vmx

    Where /vmfs/volumes/4f55f70a-0bcd954f-d11c-001ec9cf1972/MyVM/MyVM.vmx is the virtual machine configuration file path in the step 2 output.

    You see output similar to:

    displayName = "MyVM"

    Note: The display name of the virtual machine may be different to the configuration file name (for example, if you rename the virtual machine).

To release the lock on the vmware-vmx-xxx.log file and delete it:
  1. Launch vSphere Client.
  2. Click the ESXi host in the inventory and click the Virtual Machines tab.
  3. Search for the virtual machine display name noted in step 3.
  4. To release the lock on the vmware-vmx-xxx.log file, power off the virtual machine.
  5. You can delete the vmware-vmx-xxx.log file by logging in to the ESXi host and running the command:

    rm /tmp/vmware-root/vmware-vmx-xxx.log


Additional Information

For related information, see RAM disk is full (2001550)