Long periods of high CPU usage by number of Microsoft Exchange processes (e.g. msexchangerepl.exe) that are causing performance bottlenecks and can lead to temporary service disruptions.
Environment
App Control Agent: All Supported Versions
Microsoft Exchange Server: All Supported Versions
Cause
During high CPU utilization the Agent driver (Parity.sys) is spending too much time holding up the Exchange processes in kernel mode while evaluating file operations against existing rules.
Resolution
Step One: Verify Agent Configuration
Log in to the Console and navigate to Rules > Software Rules > Rapid Configs > Microsoft Exchange Server.
Verify the Rapid Config is Enabled and applied to all relevant Policies.
Reduce the number of Custom rules active on the Exchange Servers:
Isolate the Exchange Servers in a separate Policy
Ensure that Custom Rules meant for Desktop systems are not applied to the Exchange Server Policy
Upgrade to the latest version of the Agent to eliminate any potential performance enhancements or bug fixes.