There is a slowness processing NSEs
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There is a slowness processing NSEs

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Article ID: 279737

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Updated On:

Products

IT Management Suite

Issue/Introduction

Frequently, the Event Queue (under C:\ProgramData\Symantec\SMP\EventQueue\EvtQueue) on the SMP Server will receive a bunch of NSEs.
Also, many client machines have multiple NSEs accumulated in their own NSE queue (under C:\Program Files\Altiris\Altiris Agent\Queue) because they are waiting for the SMP Server to process all those accumulated NSEs.

Environment

ITMS 8.7 RU1

Cause

Known issue. There was one workstation that had 5,000 NSEs in its agent queue (due to a single corrupted Inventory nse file that caused infinite retries of a growing number of NSE files on that machine because of the bug). All of those files were transferred to the SMP Event Queue at the same time.

We had fixed that logic, so the corrupted files would be removed and not cause any further trouble:

  • The change modifies how inventory agent processes NSEs from "Outbox" folder.
  • The file that is zero length or locked or contains an empty string like INVCA21.nse is ignored and do not break NSE processing as before.

Resolution

This issue has been reported to our Broadcom Development team. We fixed this issue in our ITMS 8.7.2 release.

There is an 8.7 RU1 Point Fix that addresses this issue:

Download the SMA_SMP_8_7_1_PF_v8_20Feb2024.zip (or later) file from the following document and install it.

CUMULATIVE POST ITMS 8.7.1 POINT FIXES

Workaround:

Remove the whole Outbox folder on that affected client machine:

  • delete all *.nse files from C:\ProgramData\Symantec\Inventory Agent\Outbox\